XFree86 crashes on SMP box with multiple windows

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Robert Bernecky, Assigned: Matti)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313
BuildID:    2002031312

I'm running SUSE 7.1 on a PII ASUS P2B (two processor!)
system. When I'm running multiple navigator windows, I get sporadic
failures that take down XFree86 as well as Mozilla. I am not
able to reproduce the failure; it has hit me about 4 times in
a month.

Reproducible: Couldn't Reproduce

Expected Results:  not crashed.

Updated

16 years ago
Keywords: crash
(Reporter)

Comment 2

16 years ago
2002-05-20 bernecky@acm.org

Same failure observed with this version of Mozilla:

Mozilla 1.0 Release Candidate 2
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

I suspect a race condition with multiple navigator windows
open. I may have had incoming traffic on one window;
I hit the Back button on another window (perhaps while it was still downloading
a page), at which time Xfree86 died.

I had another interesting tarbaby failure in which the Mozilla session
froze, but other virtual windows worked -- sort of: entering some
Linux commands worked, but "top" froze after printing one screen,
which (coincidently?) ended with its last line being Mozilla.

Still unable to reproduce failure reliably.
WFM with trunk 2002073022, linux. reporter (Robert Bernecky): can you reproduce
this bug with a recent build of mozilla (for example, 1.1beta)? if so, please
comment again with details. if not, please resolve this bug as WORKSFORME. thanks.
no answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.