Long pages are only partially painted when scrolling

VERIFIED FIXED in Firefox 61

Status

()

defect
VERIFIED FIXED
Last year
Last year

People

(Reporter: mayankleoboy1, Assigned: bas.schouten)

Tracking

({regression})

Trunk
mozilla61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61blocking verified)

Details

()

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180404224504

Steps to reproduce:

1. Create new nightly profile
2. Go to https://bugzilla.mozilla.org/show_bug.cgi?id=1449255
3. Scroll down with scrollbar


Actual results:

parts of the page below the attachmnets/comment0 disappear


Expected results:

not so

2018-04-05T11:33:59: DEBUG : Found commit message:
Bug 1440753: Replace pixman regions with our own region code. r=mattwoodrow

MozReview-Commit-ID: KPsTAw3Uwa2

2018-04-05T11:33:59: INFO : The bisection is done.
2018-04-05T11:33:59: INFO : Stopped
Posted image bug.png
Blocks: 1440753
Flags: needinfo?(bas)
Assignee: nobody → bas
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(bas)
I can reproduce drawing issues here.
Status: NEW → ASSIGNED
Hmm, I saw drawing issues once, but now I don't seem to be able to reproduce them again. Any chance anyone is able to reproduce them more consistently in a minimal testcase?
Amending the subject, I've already seen this on several websites at this point.
Summary: Parts of long bugzilla pages dont paint → Long pages are only partially painted when scrolling
Is there a bug that be backed out to fix this? Because Nightly it's pretty much unusable at the moment (had to switch tab 2 or 3 times to insert this comment)
(In reply to Francesco Lodolo [:flod] from comment #6)
> Is there a bug that be backed out to fix this? Because Nightly it's pretty
> much unusable at the moment (had to switch tab 2 or 3 times to insert this
> comment)

The patch was backed out 3hours ago https://bugzilla.mozilla.org/show_bug.cgi?id=1440753#c38

I am not hitting this bug with the examples given here so I am guessing that the last nightly already has the patch backed out, did you update today?
Nightly respins are nearly complete at this point, calling this fix by backout.
Status: ASSIGNED → RESOLVED
Closed: Last year
Component: General → Graphics
Keywords: regression
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
(In reply to Pascal Chevrel:pascalc from comment #7)
> (In reply to Francesco Lodolo [:flod] from comment #6)
> > Is there a bug that be backed out to fix this? Because Nightly it's pretty
> > much unusable at the moment (had to switch tab 2 or 3 times to insert this
> > comment)
> 
> The patch was backed out 3hours ago
> https://bugzilla.mozilla.org/show_bug.cgi?id=1440753#c38
> 
> I am not hitting this bug with the examples given here so I am guessing that
> the last nightly already has the patch backed out, did you update today?

Thanks. Just received the update, it looks OK.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.