Any printing locks up print queue

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Kirk Brashear, Assigned: rods (gone))

Tracking

Trunk
mozilla1.0.1
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

I'm running RC2 on W2K Advanced Server (Domain Controller), and every time I try
to print (a USB HP Deskjet), it doesn't print and locks up the queue (so that
nothing else prints, either). Mozilla is fine, just the queue is hosed.

If I try to Cancel the job, it goes into a "Deleting" state (but never actually
deletes). So nothing else further down in the queue prints, either. If I
stop/restart the Print Spooler service, the job will finally delete upon
restart, but any further printing of other jobs (even if the print job is
created after-the-fact, i.e., reprint a Word doc outside of Mozilla) fails with
a "There was an error found when printing the doc XYZ to USB1. Do you want to
retry or cancel the job?" Retry does no good. Nothing will print until I reboot.

I'm not familiar enuff with Bugzilla to report this properly. But wanted to let
someone know. Am not sure if it's something particular to my installation or not.

When I installed RC2, I deleted the \Program Files\Mozilla directory, then
unzipped the full Talkback.

Reproducible: Always
Steps to Reproduce:
1.Print any page, e.g., http://www.mozillazine.org/articles/article2236.html
2.
3.

Actual Results:  Printer makes customary sounds as though it's about to print,
but nothing comes out. Green light is flashing (almost as if no page eject, or
no "showpage" or whatever it is). Pressing orange button to manually eject has
no effect. In queue, appears to be "Printing", but isn't, and queue is now
locked up. If try to Cancel job, will change to "Deleting" but won't delete.

Expected Results:  Should have printed.

W2K Advanced Server, Active Directory (domain controller)

Comment 1

16 years ago
I have just checked, and I can print from Mozilla 1.0rc2 to a network printer. I
am  running Win 98SE. 

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc2) Gecko/20020510
BuildID 2002051006
(Assignee)

Comment 2

16 years ago
The page prints fine with a branch build, so it isn't the page
(Reporter)

Comment 3

16 years ago
OK, had a chance to do some more, tonite (wish I had more experience
troubleshooting print queues)...

Re Tim Hunt's comment (in the Build Bar Talkback): I could wait 10 minutes or
longer, and nothing would happen, on a lightly loaded machine (my home lab) with
plenty of horsepower. Prints other docs fine, until I printed out of Moz, after
which all further printing was locked up until I rebooted. It was consistent and
reproducible.

So tonite I added the printer as a network printer on a W2K SP2 Adv Server
member server in the same AD domain (I don't have any other platforms avail,
right now), successfully printed to it via Notepad, then loaded the same version
of Moz and printed via it, with nearly the same results. However, not quite:
this time subsequent non-Moz jobs would print upon stop/restart of the service
(reboot not required), and I can get small Moz jobs to print. For example...

This time I queued:
1. a Moz print job
2. a Notepad print job
3. another Moz print job.

When I cancel #1, it goes into the "Deleting" state, but never deletes. If I
stop/restart the print spool service, #1 will then delete (altho I have to
Refresh the Queue window to see that), #2 prints, and #3 hangs. Last time I
checked, it required a reboot (hmmm, could I have been misled cuz I had two Moz
jobs queued in sequence? I didn't think so, but is possible; tonite I can
consistently get subsequent non-Moz jobs to print, from either node, with only a
stop/restart and no reboot). The green "Power" light starts flashing, which
according to my HP documentation means the printer is receiving data, yet the
Queue window is hung on Size "172/267 KB" (even after multiple refreshes over
several minutes). After about 5 minutes, the Power light stays on, and the
orange "Resume" button flashes, which supposedly indicates "action is needed"
(ala load paper or clear a jam, even tho it has paper, and is not jammed). If I
press the Resume button, it stops flashing but nothing else happens. 

Looking at the spool directory (%WINDIR%\System32\Spool\Printers), after
printing #1 (the "Getting Involved with Mozilla" page), I see a 216k 00003.spl
(which is registering as Type "Shockwave Flash Object" (is that my problem? some
sort of misconfigured registry? But it shows that for all SPL's, even those that
print successfully from Notepad), and a corresponding 00003.shd file
(registering as Type "SHD File").

After waiting another 5 minutes (typing this!), I Paused then Restarted the job;
it went to a "Printing - Restarting" state and hung (even after repeated
Refreshes over several minutes). I then stopped/restarted the Print Spool
service again. After Refreshing I noticed the size went back to "172/267". The
printer made it's "I'm about to print sounds" (i.e., moving the print head into
position, I believe), then "Never mind" (Rosanne Rosanna Danna or Emily
Litisha?) sounds (moving the print head back into the rest position, I think).
So I canceled #3, stopped/restarted the service, and it deleted. Then queued up
another Notepad job: it printed fine.

I can repeat this ad nauseum (I'd say infinitum, but not sure that's how it's
spelled!), switching back and forth between the two instances of Moz on the two
machines (AD and member servers). 

I notice that, between printing a few different Moz pages, 2 froze at Size
172/xxx (3 pages), one at 667/930 (2 pages). So I printed only page 1 of the big
one (www.cnn.com), and it showed 676/676, but still wouldn't print: after a few
minutes, green Power light stops flashing (i.e., stops receiving data) and
orange Resume flashes (action required); press Resume and nothing. So created a
small, single page doc in Composer and printed it (31/31) and BINGO! it printed OK. 

Since the Notepad pages were small, I then tried a larger non-Moz app, and
printed 2 pages out of Acrobat Reader and 3 pages (the Mozillazine home page)
out of IE v5.00.3315.1000 (total 200k+ on both)(yeah yeah I know I need to apply
security patches to IE); they printed fine, too.

I haven't had any print problems before.

If someone wants me to zip up the spooled files and send'em in, let me know.

(Assignee)

Comment 4

16 years ago
Thanks for all the detail (I never get enough detail), but I think I got a
little lost....

Does Mozilla print fine and can you cancel the print job correctly, if you do
not print any pages with plugins. (The real question is: Does everything start
getting messed up after printing the the page with Shockwave?) Maybe try
pringing the page that messes up but with no plugin in it.

Summarize the effect of the size of the page on printing.

Does a daily trunk build behave any differently than RC2? (Note, that there is a
significant difference in the code for printing between a daily trunk build and RC2)

I think about this somemore, thanks.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 5

16 years ago
Some clarifications... 

Re the "Shockwave" label on the .spl files, and the issue of plugins. This was
merely a mis-registration; I deleted the association between the extension and
Shockwave and got the same behaviors, later that night.

Re page size. I can print a small (1k source, about 31k spooled), simple (e.g.,
no images) html page just fine. Trying to print a page such as the Mozillazine
home page, CNN home page, etc. fails. I thought it might be multiple page html
docs, but when I printed the CNN home page (and only page 1 of 2), it hung
again. Whether it's size or html features (or plugins), I don't know.

So deleted the original C:\Program Files\Mozilla, and C:\Documents and
Settings\...\Application Data\Mozilla subdirs, got
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip and
installed it (creating an entirely new profile), on both nodes (the AD and
member servers, both W2K Adv Server SP2, on both am logged in with full
local/Domain/Enterprise Administrator rights). Note that since I still have
Netscape 4.7x installed on the AD, it picks up plugins from there (e.g.,
Quicktime, Shockwave, Acrobat, etc). On the member server, there is only the
Acrobat plugin.

Build 2002052108.

Tried to print http://www.mozilla.org/start/ (2 pages). Roughly same behavior:
hangs w/green Power light flashing ('receiving data') and after 5 minutes I
Cancel the job, stop/restart the Spooler service, job disappears. (On the member
server I waited 7 minutes, looked down, and noted the orange Resume light
flashing ala 'action required'; pressed it, light goes off but no result.) At
any rate, I queue up a 2 page (about 320k) Acrobat doc and it prints fine. I
print my small, simple html test page and it's fine. On both nodes.

Oh, and in System Eventlog, am getting "Event ID 45" "Document failed to print
due to GDI/Driver error in rendering." errors. (Can't believe I failed to
mention that before.) The Print Processor is set to the default WinPrint
(Default datatype: RAW).

Again, if it would help to have the spool files, I can zip'em and send'em. Or if
you have test pages you want me to try, let me know. Thanks.
(Reporter)

Comment 6

16 years ago
I uninstalled my printer drivers, then installed an updated version, and it
seems to have solved the problem. I've printed all of the same pages, no
failures, no hangs, both nodes.

HP Deskjet 930c series (932c), web page says v4.3 (test page says driver
v64.33), 19 Dec 2001, downloaded from
http://www.hp.com/cgi-bin/cposupport/swdl.pl?c=dj967&i=dj967en&p=hpdeskjet919033&n=hp+deskjet+930c+printer


Not sure what the old drivers were, e.g., not sure if they were the ones that
shipped w/W2K, or from an earlier download. Under
C:\WINNT\system32\spool\drivers\w32x86, I have a \2 and a \3 subdirectory. For
example, \2\hpfgegn0.exe (HPDJ Print Engine) is dated 4/6/2000, v1.30.13.0, as
opposed to what I believe is the now-current \3\hpzeng04.exe (HPDJ Print Engine)
dated 12/11/2000, v 2.80.0.0.

Wish I understood these subdir structures, etc., better. Would be a better
troubleshooter.

Anyways, I think this is good news. Sorry if I caused heartache. I'm rooting for
Moz (Go! Go! Go!), and thought I'd better report the "bug", just in case. Thanks.

(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1
(Assignee)

Comment 7

16 years ago
marking works for me
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
bulk verification.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.