Closed Bug 1451615 Opened 2 years ago Closed 2 years ago

Intermittent toolkit/components/extensions/test/xpcshell/test_ext_redirects.js | test_extension_302_redirect_web - [test_extension_302_redirect_web : 257] A promise chain failed to handle a rejection: Message manager disconnected

Categories

(WebExtensions :: General, defect, P5)

defect

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kmag)

References

Details

(Keywords: intermittent-failure)

[task 2018-04-05T04:13:21.138Z] 04:13:21     INFO -  TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_redirects.js | test_extension_302_redirect_web - [test_extension_302_redirect_web : 378] test result correct - "requestCompleted" == "requestCompleted"
[task 2018-04-05T04:13:21.139Z] 04:13:21     INFO -  "CONSOLE_MESSAGE: (info) Ignoring response to aborted listener for 14"
[task 2018-04-05T04:13:21.141Z] 04:13:21     INFO -  "CONSOLE_MESSAGE: (info) Ignoring response to aborted listener for 15"
[task 2018-04-05T04:13:21.142Z] 04:13:21     INFO -  "CONSOLE_MESSAGE: (info) Ignoring response to aborted listener for 16"
[task 2018-04-05T04:13:21.143Z] 04:13:21     INFO -  "CONSOLE_MESSAGE: (info) Ignoring response to aborted listener for 17"
[task 2018-04-05T04:13:21.144Z] 04:13:21     INFO -  "CONSOLE_MESSAGE: (info) Ignoring response to aborted listener for 18"
[task 2018-04-05T04:13:21.146Z] 04:13:21     INFO -  "CONSOLE_MESSAGE: (info) Ignoring response to aborted listener for 19"
[task 2018-04-05T04:13:21.147Z] 04:13:21     INFO -  "CONSOLE_MESSAGE: (info) Ignoring response to aborted listener for 20"
[task 2018-04-05T04:13:21.148Z] 04:13:21     INFO -  (xpcshell/head.js) | test run_next_test 8 pending (2)
[task 2018-04-05T04:13:21.149Z] 04:13:21     INFO -  (xpcshell/head.js) | test test_extension_302_redirect_web finished (2)
[task 2018-04-05T04:13:21.151Z] 04:13:21  WARNING -  TEST-UNEXPECTED-FAIL | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_redirects.js | test_extension_302_redirect_web - [test_extension_302_redirect_web : 257] A promise chain failed to handle a rejection: Message manager disconnected - stack: _do_main@/builds/worker/workspace/build/tests/xpcshell/head.js:211:3
[task 2018-04-05T04:13:21.152Z] 04:13:21     INFO -  _execute_test@/builds/worker/workspace/build/tests/xpcshell/head.js:517:5
[task 2018-04-05T04:13:21.153Z] 04:13:21     INFO -  @-e:1:1
[task 2018-04-05T04:13:21.155Z] 04:13:21     INFO -  Rejection date: Thu Apr 05 2018 04:13:20 GMT+0000 (UTC) - false == true
[task 2018-04-05T04:13:21.156Z] 04:13:21     INFO -  resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
[task 2018-04-05T04:13:21.157Z] 04:13:21     INFO -  /builds/worker/workspace/build/tests/xpcshell/head.js:_run_next_test:1389
[task 2018-04-05T04:13:21.159Z] 04:13:21     INFO -  /builds/worker/workspace/build/tests/xpcshell/head.js:run:669
[task 2018-04-05T04:13:21.160Z] 04:13:21     INFO -  /builds/worker/workspace/build/tests/xpcshell/head.js:_do_main:211
[task 2018-04-05T04:13:21.161Z] 04:13:21     INFO -  /builds/worker/workspace/build/tests/xpcshell/head.js:_execute_test:517
[task 2018-04-05T04:13:21.163Z] 04:13:21     INFO -  -e:null:1
[task 2018-04-05T04:13:21.164Z] 04:13:21     INFO -  exiting test
Summary: Intermittent toolkit/components/extensions/test/xpcshell/test_ext_redirects.js | xpcshell return code: 0 → Intermittent toolkit/components/extensions/test/xpcshell/test_ext_redirects.js | test_extension_302_redirect_web - [test_extension_302_redirect_web : 257] A promise chain failed to handle a rejection: Message manager disconnected
Duplicate of this bug: 1450872
https://hg.mozilla.org/mozilla-central/rev/04252d4db06a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Assignee: nobody → kmaglione+bmo
Flags: qe-verify-
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.