Mouse pointer cursor stuck as a resize cursor after resizing animations panel

VERIFIED FIXED in Firefox 61

Status

defect
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: adrian_sv, Assigned: daisuke)

Tracking

(Blocks 1 bug, {regression})

unspecified
Firefox 61

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
[Environment:]
Windows 8.1, Windows 10, Mac OSX 10.13.2
Nightly 61.0a1 2018-04-04

[Description:]
After the Animation panel is resized (or any Inspector panel) the cursor for the panel does not revert to an arrow like cursor and it looks like the resize cursor.

[Steps:]
1. Open Firefox Nightly and load https://rawgit.com/dadaa/3b73f847427025b51ba1ab7333013d0c/raw/77f3f0bb884875a179c3407f73bf8a8dd54751c9/doc_simple_animation.html.
2. Press F12.
3. Select Inspector.
4. Select Animation tab.
5. Drag and resize the Animations panel.

[Actual Result:]
4. The cursor inside the Animations panel is an arrow like cursor.
5. After the drag and resize, the cursor inside the Animations panel is now stuck in a resize cursor.

[Expected Result:]
5. After the Animations panel resize, the cursor is reset to the arrow like one. 

In the Nightly version from 2018-03-01, it seems that Animations panel has two cursors: pointer cursor and "selectable" cursor. The "selectable" cursor is not present in the latest Nightly version (2018-04-04) 

[Note:]
Note that I've set the regression flag because the Animation panel from 2018-03-01 or beta doesn't reproduce the problem.
(Reporter)

Updated

a year ago
Summary: Mouse cursor stuck after resizing animations panel → Mouse pointer cursor stuck as a resize cursor after resizing animations panel
(Assignee)

Updated

a year ago
Assignee: nobody → dakatsuka

Comment 2

a year ago
mozreview-review
Comment on attachment 8965612 [details]
Bug 1451666: Set default cursor style to root element of animation inspector and pointer style to summary graph.

https://reviewboard.mozilla.org/r/234462/#review240428
Attachment #8965612 - Flags: review?(gl) → review+

Comment 3

a year ago
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/64bbd12fd087
Set default cursor style to root element of animation inspector and pointer style to summary graph. r=gl

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/64bbd12fd087
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Status: RESOLVED → VERIFIED
The issue is fixed for the "Animations" tab from the "Inspector" section from the Developer Tools, but not for the other tabs as well: "Rules", "Layout", "Computed" and "Fonts". A new bug will be logged for the rest of the tabs.
See Also: → 1451683

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.