Unable to update the event from reply

RESOLVED FIXED in 6.2

Status

defect
--
major
RESOLVED FIXED
Last year
Last year

People

(Reporter: GeekShadow, Assigned: MakeMyDay)

Tracking

({regression})

Lightning 6.2
Dependency tree / graph

Details

Attachments

(1 attachment)

When I want to update an event using the "Update" button from someone reply, it does nothing.

In the error console I have :
ReferenceError: response is not defined  imip-bar.js:505:1

Tested with Thunderbird 60.0b1 fr locale 64bits and Lightning 6.2b1 under Ubuntu 16.04.4 x64 

STR :
- Create an event, invite someone
- This someone hits accept event
- You get a reply mail with accepted
- You click on the update button

(Works fine with stable Thunderbird)
Looks like this was introduced with bug 463402. I see a variable named aResponse and a variable named response that is in a different scope: https://dxr.mozilla.org/comm-central/search?q=response+path%3Aimip-bar.js&redirect=false
MakeMyDay, could you take a look?
Blocks: 463402
Flags: needinfo?(makemyday)
This patch takes care.
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Flags: needinfo?(makemyday)
Attachment #8965940 - Flags: review?(philipp)
Attachment #8965940 - Flags: approval-calendar-beta?(philipp)
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
OS: Linux → Unspecified
Hardware: x86_64 → Unspecified
Attachment #8965940 - Flags: review?(philipp)
Attachment #8965940 - Flags: review+
Attachment #8965940 - Flags: approval-calendar-beta?(philipp)
Attachment #8965940 - Flags: approval-calendar-beta+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/75d7ad99816e
Fix update event from reply, add missing variable declaration. r=philipp
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.3
Beta (TB 60 beta 3, Calendar 6.2):
https://hg.mozilla.org/releases/comm-beta/rev/604207d3ac30befb364e3141ede8aace5f088446
Target Milestone: 6.3 → 6.2
You need to log in before you can comment on or make changes to this bug.