Closed Bug 145177 Opened 18 years ago Closed 18 years ago

hotmail.com - Uses Passport to change profile details, Passport discriminates.

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: virkkila, Assigned: doronr)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    200251009

When you try to modify your personal profile (Options -> Personal Profile) you
get a note saying that hotmail doesn't support this browser anymore, upgrade to:
IE 4.0 or later or: netscape 4.08 or later. 

Reproducible: Always
Steps to Reproduce:
1.Log in to Hotmail
2.Go to the Options page
3.Click on Personal Profile

Actual Results:  A message saying that my browser isn't supported and that I
should upgrade.

Expected Results:  A page with my Personal profile (name, address etc.) should
come up, so I can edit them.

Workaround: I creasted a new profile, created a user.js file and put the
general.useragent.override pref to IE5.0 on Win98. After this everything worked
as expected, so it's only a matter of Hotmail not supporting mozilla on linux.
Isn't this the second time Microsoft pulls this kind of stunt?

Proposed work-around will fail once a patch for bug 136141 is committed.
the best fix for this is not to use MSN Hotspam - eeh Hotmail - at all, because
this will be a neverending game.
Look, not everyone has an option when it comes to using hotmail or
messenger(which uses your hotmail account). Besides, this is a Tech Evangelism
bug, so saying "don't use it" is really poor workaround suggestion.

We are supposed post a bug if we notice a tech evangelism bug, and I did so :^)
Besides, I would like to see this fixed and we are encouraged to post a bug here
rather than writing to the maintainer ourselves. 
depends on 141279, if not a dupe.
Depends on: 141279
For the time being, I recommend you try UABAR from www.mozdev.org/projects.html
until this is sorted out.
->evang500
Keywords: evang500
Blocks: MS
Summary: Personal profile in Hotmail cannot be modified if user string identifies as mozilla → hotmail.com - Personal profile in Hotmail cannot be modified if user string identifies as mozilla
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I've taken a closer look at where the problems are encountered and they are all
in relation to passport services. Hotmail in it "self" doesn't discriminate
browsers, it is the passport service that does. 

When you go to change your user information, you will in fact change the
passport account's user information, hence browser snooping and "denial of
service". 


It is the following items that do not work, all located on
http://nexusrdr.passport.com 

>>Personal Profile<<
Update your name, address, etc.

>>Password<<
Change your password periodically.

>>Secret Question<<
Change your secret question.
Summary: hotmail.com - Personal profile in Hotmail cannot be modified if user string identifies as mozilla → hotmail.com - Uses Passport to change profile details, Passport discriminates.
Passport login means I can't even sign up with hotmail now (just testing this
bug, I don't really want a hotmail account) as it says browser not supported.
This is with mozilla 1.0 on linux mandrake 8.2. 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605
this should have been fixed today - MS fixed teh browser sniffing used in
passport - can you check and see if it now works ?
As of today, the following steps WORKFORME:

1. Log in to MSN Messenger (called Windows Messenger on XP).
2. Tools > Options... > Personal > Edit Profile...

Actual result:   Passport profile form appears.
Expected result: Passport profile form appears.
Previous result: Access denied to Mozilla users.

I feel that the unblocking of Mozilla from .NET Passport was somehow
related to the recent release of a Windows XP service pack that adds a
new pane to Add/Remove Programs to let the user hide Internet Explorer.
-> FIXED
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.