Closed Bug 1451784 Opened 6 years ago Closed 6 years ago

RTCPeerConnection addTrack() shouldn't require two arguments.

Categories

(Core :: WebRTC, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1231414
Tracking Status
firefox61 --- affected

People

(Reporter: jib, Unassigned)

Details

Our addTrack implementation requires two arguments [1], whereas the spec [2] says one will do.

I ran into this while writing fiddles for a blog on transceivers [3]. It's easy enough to work around:

    pc.addTrack(track, new MediaStream())

but this is not without side-effects, since it adds a stream association, which may not be benign in all cases. More importantly, it's a web compat issues.

Hopefully this is just a quick webidl fix?

[1] https://searchfox.org/mozilla-central/rev/b9a5abc6cb161e0bc0bf0de5314f26d06f37d64b/dom/webidl/RTCPeerConnection.webidl#124-126
[2] http://w3c.github.io/webrtc-pc/#rtcpeerconnection-interface-extensions
[3] https://blog.mozilla.org/webrtc/rtcrtptransceiver-explored/
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.