Blue text links are too hard to see on Dark theme

VERIFIED FIXED in Firefox 61

Status

()

defect
P3
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: amylee, Assigned: dao)

Tracking

61 Branch
Firefox 62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 verified, firefox62 verified)

Details

Attachments

(2 attachments)

Reporter

Description

a year ago
The blue currently used for text links is too dark to see in Dark theme and fails in the contrast test. We are currently using Blue 40 (#45a1ff) for all text links in Dark theme on New Tab which does pass the contrast test. This should be applied to blue text links in the search bar. See screenshot for reference.
Flags: needinfo?(mverdi)
Amy and I just talked and it seems there are more issues with colors and contrast that need to be ironed out. So we'll file a new bug when we have that together.
Flags: needinfo?(mverdi)
Component: Address Bar → Theme
Assignee

Updated

a year ago
Blocks: 1408121
Priority: -- → P3
See Also: → 1455950
Assignee

Updated

a year ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Depends on: 1455950
Assignee

Updated

a year ago
See Also: 1455950
Comment on attachment 8980853 [details]
Bug 1451827 - In dark popups styled by webext themes, set --urlbar-popup-url-color and .text-link color to the same value.

https://reviewboard.mozilla.org/r/247046/#review253118
Attachment #8980853 - Flags: review?(jaws) → review+

Comment 4

a year ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c77b29b0e913
In dark popups styled by webext themes, set --urlbar-popup-url-color and .text-link color to the same value. r=jaws
hg error in cmd: hg rebase -s c77b29b0e913af5c460a12b25933f59d4458920d -d c77b29b0e913: abort: source and destination form a cycle

Comment 6

a year ago
Backout by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/17435403f576
Backed out changeset c77b29b0e913 for bc frequent failures in extensions/test/browser/browser_ext_themes_autocomplete_popup.js
Comment hidden (mozreview-request)

Comment 8

a year ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ca92bdfeca8
In dark popups styled by webext themes, set --urlbar-popup-url-color and .text-link color to the same value. r=jaws

Comment 9

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4ca92bdfeca8
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Comment on attachment 8980853 [details]
Bug 1451827 - In dark popups styled by webext themes, set --urlbar-popup-url-color and .text-link color to the same value.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1408121 
[User impact if declined]: see comment 0, contrast checks will fail for the autocomplete link color
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: see comment 0
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: low risk
[Why is the change risky/not risky?]: css only change
[String changes made/needed]:
Attachment #8980853 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Comment on attachment 8980853 [details]
Bug 1451827 - In dark popups styled by webext themes, set --urlbar-popup-url-color and .text-link color to the same value.

Fix for difficult to see text with the dark theme. Approved for 61.0b9.
Attachment #8980853 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Issue was reproduced on Firefox Nightly 61.0a1 (2018-04-05)under MacOS 10.10.5.
Confirming that the issue is fixed in Firefox 62.0a1 (2018-05-28) and Firefox 61.0b9 with Windows 10x64, Ubuntu 16.04 and MacOS 10.10.5.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.