Closed Bug 1451971 Opened 3 years ago Closed 3 years ago

Flickering navbar on ESPN

Categories

(Core :: Web Painting, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 + verified

People

(Reporter: yoasif, Assigned: mattwoodrow)

References

()

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Attached video ESPN.webm
STR: 

1. Visit http://www.espn.com/nba/scoreboard
2. Hover over navbar entries (NFL/NBA/MLB etc., or subnav below - Home, Scores, Schedule, etc.)

What happens:

Entire navbar begins to flicker/disappear, turning gray

Expected result:

As when layout.display-list.retain is set to false. 

21:30.18 INFO: Narrowed inbound regression window from [6415ccbf, d5135503] (3 builds) to [6415ccbf, d112cf7b] (2 builds) (~1 steps left)
21:30.18 INFO: No more inbound revisions, bisection finished.
21:30.18 INFO: Last good revision: 6415ccbf739f36f71548540bd92c3b86ab9e1529
21:30.18 INFO: First bad revision: d112cf7b2b60e6244099dc3b599a2444ba0d1da3
21:30.18 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6415ccbf739f36f71548540bd92c3b86ab9e1529&tochange=d112cf7b2b60e6244099dc3b599a2444ba0d1da3
Blocks: 1443027
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(matt.woodrow)
I can reproduce this in Nightly, but it looks to be working again in my local m-c build. Might have been fixed by bug 1451384.
Hmm, I did a local build after that round of merges and can still reproduce on Win10. I do have WR enabled if that matters.
Still reproduces for me on a different Win10 system as well with m-c tip and a clean profile.
Assignee: nobody → matt.woodrow
Ok, I fully understand this issue now and am working on a fix. I found a few unrelated, but interesting bugs in the process, lots to do!
Flags: needinfo?(matt.woodrow)
Comment on attachment 8966910 [details]
Bug 1451971 - Add new reftest for changing content within perspective without breaking sorting.

https://reviewboard.mozilla.org/r/235572/#review241368
Attachment #8966910 - Flags: review?(mikokm) → review+
Comment on attachment 8966911 [details]
Bug 1451971 - Rebuild the whole page when we have perspective or preserve-3d.

https://reviewboard.mozilla.org/r/235574/#review241434
Attachment #8966911 - Flags: review?(mikokm) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/79a5ebb7f796
Add new reftest for changing content within perspective without breaking sorting. r=miko
https://hg.mozilla.org/integration/autoland/rev/6a8df72533ba
Rebuild the whole page when we have perspective or preserve-3d. r=miko
https://hg.mozilla.org/mozilla-central/rev/79a5ebb7f796
https://hg.mozilla.org/mozilla-central/rev/6a8df72533ba
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Duplicate of this bug: 1453185
Summary: Flickering nabvar on ESPN → Flickering navbar on ESPN
Looks great now!
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
See Also: → 1567128
You need to log in before you can comment on or make changes to this bug.