tab_selected doesn't work unless there's a headerURL

RESOLVED FIXED in Firefox 60

Status

defect
P1
normal
RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: ntim, Assigned: ntim)

Tracking

unspecified
mozilla61
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox59 unaffected, firefox60 fixed, firefox61 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
Regression of bug 1404688.
(Assignee)

Updated

a year ago
Priority: -- → P1
(Assignee)

Updated

a year ago
Assignee: nobody → ntim.bugs
Comment hidden (mozreview-request)

Comment 2

a year ago
mozreview-review
Comment on attachment 8966792 [details]
Bug 1452019 - Fix tab_selected when lwt-image attribute is not set.

https://reviewboard.mozilla.org/r/235470/#review241222
Attachment #8966792 - Flags: review?(jaws) → review+

Comment 3

a year ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/43742a3a7677
Fix tab_selected when lwt-image attribute is not set. r=jaws

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/43742a3a7677
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
(Assignee)

Comment 5

a year ago
Comment on attachment 8966792 [details]
Bug 1452019 - Fix tab_selected when lwt-image attribute is not set.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1404688
[User impact if declined]: New theming api feature introduced in bug 1434476 is broken
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: n/a
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: CSS only, has automated test
[String changes made/needed]:
Attachment #8966792 - Flags: approval-mozilla-beta?
Comment on attachment 8966792 [details]
Bug 1452019 - Fix tab_selected when lwt-image attribute is not set.

theming regression fix, approved for 60.0b13
Attachment #8966792 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

10 months ago
Product: Toolkit → WebExtensions

Updated

10 months ago
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.