Intermittent PROCESS-CRASH | Main app process exited normally | application crashed [@ mozilla::dom::WorkerPrivate::Thaw] after Assertion failure: mParentFrozen, at /builds/worker/workspace/build/src/dom/workers/WorkerPrivate.cpp:1803

RESOLVED FIXED in Firefox 62

Status

()

defect
P3
critical
RESOLVED FIXED
Last year
10 months ago

People

(Reporter: intermittent-bug-filer, Assigned: baku)

Tracking

({crash, intermittent-failure})

unspecified
mozilla63
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 wontfix, firefox62 fixed, firefox63 fixed)

Details

(Whiteboard: [stockwell unknown], crash signature)

Attachments

(1 attachment)

Reporter

Description

Last year
treeherder
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=172235456&repo=autoland

https://queue.taskcluster.net/v1/task/cG0MQe3xTXG0IDFiO0g2Nw/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-06T05:06:57.758Z] 05:06:57     INFO - GECKO(1877) | Assertion failure: mParentFrozen, at /builds/worker/workspace/build/src/dom/workers/WorkerPrivate.cpp:1804

[task 2018-04-06T05:07:24.865Z] 05:07:24     INFO - mozcrash Copy/paste: /usr/local/bin/linux64-minidump_stackwalk /tmp/tmpPz4XSc.mozrunner/minidumps/5c4451e6-b482-ffda-6fb5-5b3dc82c093f.dmp /builds/worker/workspace/build/symbols
[task 2018-04-06T05:07:30.967Z] 05:07:30     INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/5c4451e6-b482-ffda-6fb5-5b3dc82c093f.dmp
[task 2018-04-06T05:07:30.968Z] 05:07:30     INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/5c4451e6-b482-ffda-6fb5-5b3dc82c093f.extra
[task 2018-04-06T05:07:31.060Z] 05:07:31     INFO - PROCESS-CRASH | Main app process exited normally | application crashed [@ mozilla::dom::WorkerPrivate::Thaw]
[task 2018-04-06T05:07:31.061Z] 05:07:31     INFO - Crash dump filename: /tmp/tmpPz4XSc.mozrunner/minidumps/5c4451e6-b482-ffda-6fb5-5b3dc82c093f.dmp
[task 2018-04-06T05:07:31.062Z] 05:07:31     INFO - Operating system: Linux
[task 2018-04-06T05:07:31.063Z] 05:07:31     INFO -                   0.0.0 Linux 4.4.0-1014-aws #14taskcluster1-Ubuntu SMP Tue Apr 3 10:27:00 UTC 2018 x86_64
[task 2018-04-06T05:07:31.063Z] 05:07:31     INFO - CPU: amd64
[task 2018-04-06T05:07:31.064Z] 05:07:31     INFO -      family 6 model 62 stepping 4
[task 2018-04-06T05:07:31.065Z] 05:07:31     INFO -      2 CPUs
[task 2018-04-06T05:07:31.065Z] 05:07:31     INFO - 
[task 2018-04-06T05:07:31.066Z] 05:07:31     INFO - GPU: UNKNOWN
[task 2018-04-06T05:07:31.067Z] 05:07:31     INFO - 
[task 2018-04-06T05:07:31.067Z] 05:07:31     INFO - Crash reason:  SIGSEGV
[task 2018-04-06T05:07:31.068Z] 05:07:31     INFO - Crash address: 0x0
[task 2018-04-06T05:07:31.069Z] 05:07:31     INFO - Process uptime: not available
[task 2018-04-06T05:07:31.069Z] 05:07:31     INFO - 
[task 2018-04-06T05:07:31.069Z] 05:07:31     INFO - Thread 0 (crashed)
[task 2018-04-06T05:07:31.070Z] 05:07:31     INFO -  0  libxul.so!mozilla::dom::WorkerPrivate::Thaw [WorkerPrivate.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 1823 + 0x5]
[task 2018-04-06T05:07:31.070Z] 05:07:31     INFO -     rax = 0x0000000000000000   rdx = 0x0000000000000000
[task 2018-04-06T05:07:31.071Z] 05:07:31     INFO -     rcx = 0x00007fa50977e2dd   rbx = 0x00007fa4e4316800
[task 2018-04-06T05:07:31.072Z] 05:07:31     INFO -     rsi = 0x00007fa509a4d770   rdi = 0x00007fa509a4c540
[task 2018-04-06T05:07:31.072Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe41c0   rsp = 0x00007ffd65fe4150
[task 2018-04-06T05:07:31.074Z] 05:07:31     INFO -      r8 = 0x00007fa509a4d770    r9 = 0x00007fa50ad2e740
[task 2018-04-06T05:07:31.075Z] 05:07:31     INFO -     r10 = 0x000000000000004c   r11 = 0x0000000000000000
[task 2018-04-06T05:07:31.075Z] 05:07:31     INFO -     r12 = 0x0000000000000001   r13 = 0x00007fa4e43b0c20
[task 2018-04-06T05:07:31.075Z] 05:07:31     INFO -     r14 = 0x00007fa4e43b0c00   r15 = 0x0000000000000000
[task 2018-04-06T05:07:31.076Z] 05:07:31     INFO -     rip = 0x00007fa4f9d1c709
[task 2018-04-06T05:07:31.076Z] 05:07:31     INFO -     Found by: given as instruction pointer in context
[task 2018-04-06T05:07:31.076Z] 05:07:31     INFO -  1  libxul.so!mozilla::dom::workerinternals::RuntimeService::ThawWorkersForWindow [RuntimeService.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 2230 + 0x5]
[task 2018-04-06T05:07:31.077Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4200   rsp = 0x00007ffd65fe41d0
[task 2018-04-06T05:07:31.077Z] 05:07:31     INFO -     rip = 0x00007fa4f9cfc0fb
[task 2018-04-06T05:07:31.078Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.079Z] 05:07:31     INFO -  2  libxul.so!nsGlobalWindowInner::ThawInternal [nsGlobalWindowInner.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 6316 + 0x8]
[task 2018-04-06T05:07:31.080Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4220   rsp = 0x00007ffd65fe4210
[task 2018-04-06T05:07:31.081Z] 05:07:31     INFO -     rip = 0x00007fa4f8dba62d
[task 2018-04-06T05:07:31.081Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.082Z] 05:07:31     INFO -  3  libxul.so!nsGlobalWindowInner::Thaw [nsGlobalWindowInner.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 6291 + 0x8]
[task 2018-04-06T05:07:31.083Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4240   rsp = 0x00007ffd65fe4230
[task 2018-04-06T05:07:31.084Z] 05:07:31     INFO -     rip = 0x00007fa4f8dbe284
[task 2018-04-06T05:07:31.085Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.086Z] 05:07:31     INFO -  4  libxul.so!nsGlobalWindowOuter::RestoreWindowState [nsGlobalWindowOuter.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 7415 + 0x8]
[task 2018-04-06T05:07:31.086Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe42a0   rsp = 0x00007ffd65fe4250
[task 2018-04-06T05:07:31.087Z] 05:07:31     INFO -     rip = 0x00007fa4f8dccb69
[task 2018-04-06T05:07:31.088Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.089Z] 05:07:31     INFO -  5  libxul.so!nsDocShell::RestoreFromHistory [nsDocShell.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 8593 + 0x29]
[task 2018-04-06T05:07:31.089Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4430   rsp = 0x00007ffd65fe42b0
[task 2018-04-06T05:07:31.090Z] 05:07:31     INFO -     rip = 0x00007fa4faae4681
[task 2018-04-06T05:07:31.091Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.091Z] 05:07:31     INFO -  6  libxul.so!nsDocShell::RestorePresentationEvent::Run [nsDocShell.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 8000 + 0xd]
[task 2018-04-06T05:07:31.092Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4440   rsp = 0x00007ffd65fe4440
[task 2018-04-06T05:07:31.092Z] 05:07:31     INFO -     rip = 0x00007fa4faae4f2c
[task 2018-04-06T05:07:31.092Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.093Z] 05:07:31     INFO -  7  libxul.so!mozilla::SchedulerGroup::Runnable::Run [SchedulerGroup.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 415 + 0x1c]
[task 2018-04-06T05:07:31.093Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe44f0   rsp = 0x00007ffd65fe4450
[task 2018-04-06T05:07:31.095Z] 05:07:31     INFO -     rip = 0x00007fa4f8273506
[task 2018-04-06T05:07:31.096Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.097Z] 05:07:31     INFO -  8  libxul.so!nsThread::ProcessNextEvent [nsThread.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 1096 + 0x15]
[task 2018-04-06T05:07:31.097Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4ad0   rsp = 0x00007ffd65fe4500
[task 2018-04-06T05:07:31.098Z] 05:07:31     INFO -     rip = 0x00007fa4f827a492
[task 2018-04-06T05:07:31.098Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.099Z] 05:07:31     INFO -  9  libxul.so!NS_ProcessNextEvent [nsThreadUtils.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 519 + 0x11]
[task 2018-04-06T05:07:31.099Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4b00   rsp = 0x00007ffd65fe4ae0
[task 2018-04-06T05:07:31.101Z] 05:07:31     INFO -     rip = 0x00007fa4f8280d99
[task 2018-04-06T05:07:31.101Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.101Z] 05:07:31     INFO - 10  libxul.so!mozilla::ipc::MessagePump::Run [MessagePump.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 97 + 0xa]
[task 2018-04-06T05:07:31.102Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4b60   rsp = 0x00007ffd65fe4b10
[task 2018-04-06T05:07:31.102Z] 05:07:31     INFO -     rip = 0x00007fa4f865b108
[task 2018-04-06T05:07:31.103Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.103Z] 05:07:31     INFO - 11  libxul.so!MessageLoop::RunInternal [message_loop.cc:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 326 + 0x17]
[task 2018-04-06T05:07:31.104Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4ba0   rsp = 0x00007ffd65fe4b70
[task 2018-04-06T05:07:31.104Z] 05:07:31     INFO -     rip = 0x00007fa4f86302e9
[task 2018-04-06T05:07:31.105Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.105Z] 05:07:31     INFO - 12  libxul.so!MessageLoop::Run [message_loop.cc:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 319 + 0x8]
[task 2018-04-06T05:07:31.106Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4be0   rsp = 0x00007ffd65fe4bb0
[task 2018-04-06T05:07:31.106Z] 05:07:31     INFO -     rip = 0x00007fa4f8630315
[task 2018-04-06T05:07:31.107Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.107Z] 05:07:31     INFO - 13  libxul.so!nsBaseAppShell::Run [nsBaseAppShell.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 157 + 0xd]
[task 2018-04-06T05:07:31.108Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4c00   rsp = 0x00007ffd65fe4bf0
[task 2018-04-06T05:07:31.108Z] 05:07:31     INFO -     rip = 0x00007fa4f9ee8531
[task 2018-04-06T05:07:31.109Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.109Z] 05:07:31     INFO - 14  libxul.so!XRE_RunAppShell [nsEmbedFunctions.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 893 + 0x11]
[task 2018-04-06T05:07:31.110Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4c40   rsp = 0x00007ffd65fe4c10
[task 2018-04-06T05:07:31.110Z] 05:07:31     INFO -     rip = 0x00007fa4fad7b096
[task 2018-04-06T05:07:31.111Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.111Z] 05:07:31     INFO - 15  libxul.so!mozilla::ipc::MessagePumpForChildProcess::Run [MessagePump.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 269 + 0x5]
[task 2018-04-06T05:07:31.111Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4c70   rsp = 0x00007ffd65fe4c50
[task 2018-04-06T05:07:31.112Z] 05:07:31     INFO -     rip = 0x00007fa4f865b1c9
[task 2018-04-06T05:07:31.112Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.113Z] 05:07:31     INFO - 16  libxul.so!MessageLoop::RunInternal [message_loop.cc:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 326 + 0x17]
[task 2018-04-06T05:07:31.113Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4cb0   rsp = 0x00007ffd65fe4c80
[task 2018-04-06T05:07:31.114Z] 05:07:31     INFO -     rip = 0x00007fa4f86302e9
[task 2018-04-06T05:07:31.114Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.115Z] 05:07:31     INFO - 17  libxul.so!MessageLoop::Run [message_loop.cc:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 319 + 0x8]
[task 2018-04-06T05:07:31.116Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4cf0   rsp = 0x00007ffd65fe4cc0
[task 2018-04-06T05:07:31.116Z] 05:07:31     INFO -     rip = 0x00007fa4f8630315
[task 2018-04-06T05:07:31.117Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.117Z] 05:07:31     INFO - 18  libxul.so!XRE_InitChildProcess [nsEmbedFunctions.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 719 + 0x8]
[task 2018-04-06T05:07:31.117Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe4fc0   rsp = 0x00007ffd65fe4d00
[task 2018-04-06T05:07:31.118Z] 05:07:31     INFO -     rip = 0x00007fa4fad7b5b9
[task 2018-04-06T05:07:31.119Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.120Z] 05:07:31     INFO - 19  firefox!content_process_main [plugin-container.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 50 + 0x14]
[task 2018-04-06T05:07:31.120Z] 05:07:31     INFO -     rbp = 0x00007ffd65fe5000   rsp = 0x00007ffd65fe4fd0
[task 2018-04-06T05:07:31.121Z] 05:07:31     INFO -     rip = 0x0000000000406957
[task 2018-04-06T05:07:31.121Z] 05:07:31     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T05:07:31.122Z] 05:07:31     INFO - 20  firefox!main [nsBrowserApp.cpp:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 280 + 0x11]
[task 2018-04-06T05:07:31.122Z] 05:07:31     INFO -     rbx = 0x0000000000000012   rbp = 0x00007ffd65fe5030
[task 2018-04-06T05:07:31.124Z] 05:07:31     INFO -     rsp = 0x00007ffd65fe5010   r12 = 0x00007ffd65fe5118
[task 2018-04-06T05:07:31.124Z] 05:07:31     INFO -     rip = 0x00000000004064c4
[task 2018-04-06T05:07:31.125Z] 05:07:31     INFO -     Found by: call frame info
[task 2018-04-06T05:07:31.126Z] 05:07:31     INFO - 21  libc-2.23.so + 0x20830
[task 2018-04-06T05:07:31.126Z] 05:07:31     INFO -     rbx = 0x0000000000000000   rbp = 0x0000000000431840
[task 2018-04-06T05:07:31.127Z] 05:07:31     INFO -     rsp = 0x00007ffd65fe5040   r12 = 0x00000000004066a4
[task 2018-04-06T05:07:31.128Z] 05:07:31     INFO -     r13 = 0x00007ffd65fe5110   r14 = 0x0000000000000000
[task 2018-04-06T05:07:31.128Z] 05:07:31     INFO -     rip = 0x00007fa5096a7830
[task 2018-04-06T05:07:31.128Z] 05:07:31     INFO -     Found by: call frame info
[task 2018-04-06T05:07:31.129Z] 05:07:31     INFO - 22  firefox!MOZ_ReportAssertionFailure [Assertions.h:90a06cdcb48f86ddc4c32df3b5443f818adf8d81 : 164 + 0x5]
[task 2018-04-06T05:07:31.130Z] 05:07:31     INFO -     rsp = 0x00007ffd65fe5060   rip = 0x00000000004063e8
[task 2018-04-06T05:07:31.130Z] 05:07:31     INFO -     Found by: stack scanning
Comment hidden (Intermittent Failures Robot)
Hi! Did some retriggers to find the root cause of this failures and here are my findings: https://goo.gl/XZYwVa
From what I can see it seems that this push from Johann is where they started https://goo.gl/zoM9Lt

Need a second opinion from Joel and maybe Johann can take a look at this. Thanks.
Flags: needinfo?(jmaher)
Flags: needinfo?(jhofmann)
Summary: Intermittent PROCESS-CRASH | Main app process exited normally | application crashed [@ mozilla::dom::WorkerPrivate::Thaw] after Assertion failure: mParentFrozen → Intermittent Assertion failure: mParentFrozen, at /builds/worker/workspace/build/src/dom/workers/WorkerPrivate.cpp:1804
Bug 1348223 did not even remotely touch that code or that test, unless I'm missing something. I'm not at all familiar with Workers.

Forwarding to bkelly who knows more about this code. Ben, did something change here recently?
Flags: needinfo?(jhofmann) → needinfo?(bkelly)
Andrea, do you have any bandwidth to look at this?  Or could it be related to your recent worker lifecycle changes?
Flags: needinfo?(amarchesini)
Crash Signature: [@ mozilla::dom::WorkerPrivate::Thaw] → [@ mozilla::dom::WorkerPrivate::Thaw] [@ mozilla::dom::WorkerPrivate::Thaw(nsPIDOMWindowInner *)]
Promoting to P3.
Priority: P5 → P3
Duplicate of this bug: 1453225
Summary: Intermittent Assertion failure: mParentFrozen, at /builds/worker/workspace/build/src/dom/workers/WorkerPrivate.cpp:1804 → Intermittent PROCESS-CRASH | Main app process exited normally | application crashed [@ mozilla::dom::WorkerPrivate::Thaw] after Assertion failure: mParentFrozen, at /builds/worker/workspace/build/src/dom/workers/WorkerPrivate.cpp:1803
Comment hidden (Intermittent Failures Robot)
There are 36 failures in the past 7 days.
Platforms: Linux x64, linux64-qr, OS X 10.10, windows10-64 all debug and one occurrence on linux64-ccov opt.
Recent log failure: https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-inbound&job_id=174484280&lineNumber=6838

Relevant part of the log: 
08:47:42     INFO -  GECKO(6356) | #01: mozilla::dom::workerinternals::RuntimeService::ThawWorkersForWindow(nsPIDOMWindowInner *) [dom/workers/RuntimeService.cpp:2238]
08:47:42     INFO -  GECKO(6356) | #02: mozilla::dom::ThawWorkersForWindow(nsPIDOMWindowInner *) [dom/workers/RuntimeService.cpp:2842]
08:47:42     INFO -  GECKO(6356) | #03: nsGlobalWindowInner::ThawInternal() [dom/base/nsGlobalWindowInner.cpp:6260]
08:47:42     INFO -  GECKO(6356) | #04: nsGlobalWindowInner::Thaw() [dom/base/nsGlobalWindowInner.cpp:6234]
08:47:42     INFO -  GECKO(6356) | #05: nsGlobalWindowOuter::RestoreWindowState(nsISupports *) [dom/base/nsGlobalWindowOuter.cpp:7286]
08:47:42     INFO -  GECKO(6356) | #06: nsDocShell::RestoreFromHistory() [docshell/base/nsDocShell.cpp:8545]
08:47:42     INFO -  GECKO(6356) | #07: nsDocShell::RestorePresentationEvent::Run() [docshell/base/nsDocShell.cpp:7953]
08:47:42     INFO -  GECKO(6356) | #08: mozilla::SchedulerGroup::Runnable::Run() [xpcom/threads/SchedulerGroup.cpp:341]
08:47:42     INFO -  GECKO(6356) | #09: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1100]
08:47:42     INFO -  GECKO(6356) | #10: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/threads/nsThreadUtils.cpp:519]
08:47:42     INFO -  GECKO(6356) | #11: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:97]
08:47:42     INFO -  GECKO(6356) | #12: mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:301]
08:47:42     INFO -  GECKO(6356) | #13: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:320]
08:47:42     INFO -  GECKO(6356) | #14: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:300]
08:47:42     INFO -  GECKO(6356) | #15: nsBaseAppShell::Run() [widget/nsBaseAppShell.cpp:159]
08:47:42     INFO -  GECKO(6356) | #16: nsAppShell::Run() [widget/windows/nsAppShell.cpp:403]
08:47:42     INFO -  GECKO(6356) | #17: XRE_RunAppShell() [toolkit/xre/nsEmbedFunctions.cpp:893]
08:47:42     INFO -  GECKO(6356) | #18: mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:269]
08:47:42     INFO -  GECKO(6356) | #19: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:320]
08:47:42     INFO -  GECKO(6356) | #20: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:300]
08:47:42     INFO -  GECKO(6356) | #21: XRE_InitChildProcess(int,char * * const,XREChildData const *) [toolkit/xre/nsEmbedFunctions.cpp:723]
08:47:42     INFO -  GECKO(6356) | #22: content_process_main(mozilla::Bootstrap *,int,char * * const) [ipc/contentproc/plugin-container.cpp:51]
08:47:42     INFO -  GECKO(6356) | #23: NS_internal_main(int,char * *,char * *) [browser/app/nsBrowserApp.cpp:283]
08:47:42     INFO -  GECKO(6356) | #24: wmain [toolkit/xre/nsWindowsWMain.cpp:132]
08:47:42     INFO -  GECKO(6356) | #25: static int __scrt_common_main_seh() [f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:283]
08:47:42     INFO -  GECKO(6356) | #26: KERNEL32.DLL + 0x12774
08:47:42     INFO -  GECKO(6356) | #27: ntdll.dll + 0x70d61

:mdaly Can you please take a look?
Flags: needinfo?(mdaly)
Whiteboard: [stockwell needswork:owner]
:baku when you have time.
Flags: needinfo?(mdaly)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
:baku are there any updates here?
Comment hidden (Intermittent Failures Robot)
Duplicate of this bug: 1459654
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Flags: needinfo?(bkelly)
Comment hidden (Intermittent Failures Robot)
Attachment #8990604 - Flags: review?(bugs) → review+

Comment 27

Last year
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4076daf69ad
Fixing a DOM Worker assertion related to frozen/thrown windows, r=smaug
Comment hidden (Intermittent Failures Robot)

Comment 29

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/f4076daf69ad
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.