Closed Bug 1452162 Opened 2 years ago Closed 2 years ago

Intermittent /workers/semantics/multiple-workers/005.html | application crashed [@ TimerThread::Run]

Categories

(Core :: DOM: Workers, defect, P5, critical)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1334383

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: crash, intermittent-failure)

Crash Data

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=172305657&repo=autoland

https://queue.taskcluster.net/v1/task/OYhriQQHR5i0PsAUQA_EEQ/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-06T14:51:47.525Z] 14:51:47     INFO - PID 10150 | Assertion failure: rc != 0 (destroyed timer off its target thread!), at /builds/worker/workspace/build/src/xpcom/threads/TimerThread.cpp:480
[task 2018-04-06T14:51:47.675Z] 14:51:47     INFO - PID 10150 | #01: TimerThread::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-06T14:51:47.683Z] 14:51:47     INFO - PID 10150 | #02: nsThread::ProcessNextEvent(bool, bool*) [clone .part.206] (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-06T14:51:47.687Z] 14:51:47     INFO - PID 10150 | #03: NS_ProcessNextEvent(nsIThread*, bool) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-06T14:51:47.691Z] 14:51:47     INFO - PID 10150 | #04: mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-06T14:51:47.696Z] 14:51:47     INFO - PID 10150 | #05: MessageLoop::RunInternal() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-06T14:51:47.704Z] 14:51:47     INFO - PID 10150 | #06: MessageLoop::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-06T14:51:47.706Z] 14:51:47     INFO - PID 10150 | #07: nsThread::ThreadFunc(void*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-06T14:51:47.823Z] 14:51:47     INFO - PID 10150 | #08: _pt_root (/builds/worker/workspace/build/application/firefox/libnspr4.so)
[task 2018-04-06T14:51:47.926Z] 14:51:47     INFO - PID 10150 | #09: start_thread (/lib/i386-linux-gnu/libpthread.so.0)
[task 2018-04-06T14:51:47.926Z] 14:51:47     INFO - PID 10150 | ExceptionHandler::GenerateDump cloned child 10268
[task 2018-04-06T14:51:47.927Z] 14:51:47     INFO - PID 10150 | ExceptionHandler::SendContinueSignalToChild sent continue signal to child
[task 2018-04-06T14:51:47.927Z] 14:51:47     INFO - PID 10150 | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[task 2018-04-06T14:51:47.948Z] 14:51:47     INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/HK9tuVF4RCWG-Zkl8skVoA/artifacts/public/build/target.crashreporter-symbols.zip
[task 2018-04-06T14:51:53.308Z] 14:51:53     INFO - mozcrash Copy/paste: /usr/local/bin/linux64-minidump_stackwalk /tmp/tmpA4snZd.mozrunner/minidumps/2c8e70dc-e82c-9378-1c42-803cc2df3404.dmp /tmp/tmpq4QzDL
[task 2018-04-06T14:51:58.797Z] 14:51:58     INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/2c8e70dc-e82c-9378-1c42-803cc2df3404.dmp
[task 2018-04-06T14:51:58.799Z] 14:51:58     INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/2c8e70dc-e82c-9378-1c42-803cc2df3404.extra
[task 2018-04-06T14:51:58.944Z] 14:51:58     INFO - PROCESS-CRASH | /workers/semantics/multiple-workers/005.html | application crashed [@ TimerThread::Run]
[task 2018-04-06T14:51:58.944Z] 14:51:58     INFO - Crash dump filename: /tmp/tmpA4snZd.mozrunner/minidumps/2c8e70dc-e82c-9378-1c42-803cc2df3404.dmp
[task 2018-04-06T14:51:58.944Z] 14:51:58     INFO - Operating system: Linux
[task 2018-04-06T14:51:58.945Z] 14:51:58     INFO -                   0.0.0 Linux 4.4.0-1014-aws #14taskcluster1-Ubuntu SMP Tue Apr 3 10:27:00 UTC 2018 x86_64
[task 2018-04-06T14:51:58.945Z] 14:51:58     INFO - CPU: x86
[task 2018-04-06T14:51:58.945Z] 14:51:58     INFO -      GenuineIntel family 6 model 62 stepping 4
[task 2018-04-06T14:51:58.947Z] 14:51:58     INFO -      4 CPUs
[task 2018-04-06T14:51:58.947Z] 14:51:58     INFO - 
[task 2018-04-06T14:51:58.948Z] 14:51:58     INFO - GPU: UNKNOWN
[task 2018-04-06T14:51:58.948Z] 14:51:58     INFO - 
[task 2018-04-06T14:51:58.948Z] 14:51:58     INFO - Crash reason:  SIGSEGV
[task 2018-04-06T14:51:58.949Z] 14:51:58     INFO - Crash address: 0x0
[task 2018-04-06T14:51:58.950Z] 14:51:58     INFO - Process uptime: not available
[task 2018-04-06T14:51:58.950Z] 14:51:58     INFO - 
[task 2018-04-06T14:51:58.951Z] 14:51:58     INFO - Thread 12 (crashed)
[task 2018-04-06T14:51:58.952Z] 14:51:58     INFO -  0  libxul.so!TimerThread::Run [TimerThread.cpp:1d725bf734be646047bf90f9372b3b23496c4729 : 415 + 0x16]
[task 2018-04-06T14:51:58.952Z] 14:51:58     INFO -     eip = 0xef03835f   esp = 0xe67fcbf0   ebp = 0xe67fcc78   ebx = 0xf5490000
[task 2018-04-06T14:51:58.953Z] 14:51:58     INFO -     esi = 0xe67fcc58   edi = 0xf712c5c0   eax = 0x00000000   ecx = 0xf7506864
[task 2018-04-06T14:51:58.954Z] 14:51:58     INFO -     edx = 0x00000000   efl = 0x00210282
[task 2018-04-06T14:51:58.954Z] 14:51:58     INFO -     Found by: given as instruction pointer in context
[task 2018-04-06T14:51:58.956Z] 14:51:58     INFO -  1  libxul.so!nsThread::ProcessNextEvent [nsThread.cpp:1d725bf734be646047bf90f9372b3b23496c4729 : 1096 + 0x17]
[task 2018-04-06T14:51:58.956Z] 14:51:58     INFO -     eip = 0xef03625c   esp = 0xe67fcc80   ebp = 0xe67fd1d8
[task 2018-04-06T14:51:58.957Z] 14:51:58     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T14:51:58.957Z] 14:51:58     INFO -  2  libxul.so!NS_ProcessNextEvent [nsThreadUtils.cpp:1d725bf734be646047bf90f9372b3b23496c4729 : 519 + 0xc]
[task 2018-04-06T14:51:58.957Z] 14:51:58     INFO -     eip = 0xef03cd6c   esp = 0xe67fd1e0   ebp = 0xe67fd218
[task 2018-04-06T14:51:58.957Z] 14:51:58     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T14:51:58.957Z] 14:51:58     INFO -  3  libxul.so!mozilla::ipc::MessagePumpForNonMainThreads::Run [MessagePump.cpp:1d725bf734be646047bf90f9372b3b23496c4729 : 364 + 0xc]
[task 2018-04-06T14:51:58.957Z] 14:51:58     INFO -     eip = 0xef42ede8   esp = 0xe67fd220   ebp = 0xe67fd268
[task 2018-04-06T14:51:58.958Z] 14:51:58     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T14:51:58.958Z] 14:51:58     INFO -  4  libxul.so!MessageLoop::RunInternal [message_loop.cc:1d725bf734be646047bf90f9372b3b23496c4729 : 326 + 0x14]
[task 2018-04-06T14:51:58.958Z] 14:51:58     INFO -     eip = 0xef401e78   esp = 0xe67fd270   ebp = 0xe67fd298
[task 2018-04-06T14:51:58.958Z] 14:51:58     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T14:51:58.958Z] 14:51:58     INFO -  5  libxul.so!MessageLoop::Run [message_loop.cc:1d725bf734be646047bf90f9372b3b23496c4729 : 319 + 0x8]
[task 2018-04-06T14:51:58.958Z] 14:51:58     INFO -     eip = 0xef401e9f   esp = 0xe67fd2a0   ebp = 0xe67fd2c8
[task 2018-04-06T14:51:58.958Z] 14:51:58     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T14:51:58.959Z] 14:51:58     INFO -  6  libxul.so!nsThread::ThreadFunc [nsThread.cpp:1d725bf734be646047bf90f9372b3b23496c4729 : 425 + 0x9]
[task 2018-04-06T14:51:58.959Z] 14:51:58     INFO -     eip = 0xef036c85   esp = 0xe67fd2d0   ebp = 0xe67fd318
[task 2018-04-06T14:51:58.959Z] 14:51:58     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T14:51:58.959Z] 14:51:58     INFO -  7  libnspr4.so!_pt_root [ptthread.c:1d725bf734be646047bf90f9372b3b23496c4729 : 201 + 0x7]
[task 2018-04-06T14:51:58.959Z] 14:51:58     INFO -     eip = 0xf7339fb0   esp = 0xe67fd320   ebp = 0xe67fd368
[task 2018-04-06T14:51:58.959Z] 14:51:58     INFO -     Found by: previous frame's frame pointer
[task 2018-04-06T14:51:58.960Z] 14:51:58     INFO -  8  libpthread-2.23.so + 0x6295
[task 2018-04-06T14:51:58.960Z] 14:51:58     INFO -     eip = 0xf7707295   esp = 0xe67fd370   ebp = 0xe67fd428   ebx = 0x00000000
[task 2018-04-06T14:51:58.960Z] 14:51:58     INFO -     esi = 0x00000000   edi = 0x003d0f00
[task 2018-04-06T14:51:58.960Z] 14:51:58     INFO -     Found by: call frame info
[task 2018-04-06T14:51:58.960Z] 14:51:58     INFO -  9  libc-2.23.so + 0xe70ae
[task 2018-04-06T14:51:58.960Z] 14:51:58     INFO -     eip = 0xf743a0ae   esp = 0xe67fd430   ebp = 0x00000000
[task 2018-04-06T14:51:58.960Z] 14:51:58     INFO -     Found by: previous frame's frame pointer
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334383
You need to log in before you can comment on or make changes to this bug.