charset in meta tag behaves strange inside frames

VERIFIED DUPLICATE of bug 132006

Status

()

Core
Internationalization
--
major
VERIFIED DUPLICATE of bug 132006
16 years ago
16 years ago

People

(Reporter: c.h.ip, Assigned: Roy Yokoyama)

Tracking

({intl})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051009 (1.0RC2)

Charset in meta tag, inside frames, exhibits a strange problem in RC2.

Some characters becomes rubbish characters for the first time loading of a web
page.  One need to manual invoke "View->character coding->trad. Chinese" to correct.

Such behaviour won't happen if I run 1.0rc1 instead of 1.0rc2.  

Also note that unders Windows, such behaviour won't happen.

My OS: Mandrake 8.1 (installed with Traditional Chinese)

Reproducible: Always
Steps to Reproduce:
1. browser full.mingpaonews.com with RC2, see the first page.

Actual Results:  Some characters on the first page (inside a frame) became rubbish.

Expected Results:  The browser should handle the charset well, as fonts have
been installed and used.

I've produced a screenshot to illstrate the problem.

http://www.cmpair.com/chip/mozilla_bug.jpg

Two version of Mozilla is running side-by-side and browsing the same page
(full.mingpaonews.com), the left one is 1.0RC2 that exhibits the problem, and
the right one is 1.0RC1, looks good.

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 1

16 years ago
It sounds another dup of bug 132006 - on RC2 builds, when I set auto-detect
Chinese will see this, but when I set auto-detect Off will get this pape display
correctly.

I checked it on latest trunk build on linux and windows, can not reproduce this
problem.  Unless I select auto-detect SimpChinese, but I guess it's not a good
option to select this tradChinese page as auto-detect SimpChinese.
(Assignee)

Comment 2

16 years ago
marking as dup

*** This bug has been marked as a duplicate of 132006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Mark as verified.  Please reopen if still see the problem on latest build after
bug 132006 checked into branch or trunk build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.