Margins settings aren't remembered

RESOLVED FIXED in mozilla1.2final

Status

()

Core
Printing: Output
P2
normal
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Aleksander Adamowski, Assigned: rods (gone))

Tracking

Trunk
mozilla1.2final
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

16 years ago
Build: 2002051521 trunk.
Reproducible: always

To reproduce:
1. Launch Mozilla
2. Enter File -> Page Setup -> Margins & Header/Footer
3. Change the top margin to 0.8 Inches and click OK
4. Test the setting by printing something, or entering Page Setup again: top
margin should still be at 0.8
5. Quite Mozilla and restart it
6. Enter Page Setup again.

Results: top margin is back at 0.5

Expected results: top margin should be at 0.8, as it was left before closing
Mozilla.
(Assignee)

Comment 1

16 years ago
We are purposely not doing this at th moment. If it is something a lot of folks
want I will attach the patch.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Assignee)

Comment 2

16 years ago
Created attachment 84051 [details] [diff] [review]
patch

Patch for having margins saved
(Assignee)

Updated

16 years ago
Priority: -- → P2
(Reporter)

Comment 3

16 years ago
What's the purpose of not doing it?
(Assignee)

Comment 4

16 years ago
Well, it seems reasonsable and IE remembers the amrgin settings from one
execution to another.

The patch is no risk nominating for nsbeta1, this effects any platforms using
the XP PageSetup (Mac9, Win, Linux, OS2)
Keywords: nsbeta1
Target Milestone: Future → mozilla1.0
(Assignee)

Updated

16 years ago
Keywords: nsbeta1
Target Milestone: mozilla1.0 → Future
(Assignee)

Comment 5

16 years ago
Comment on attachment 84051 [details] [diff] [review]
patch

this doesn't work
Attachment #84051 - Attachment is obsolete: true
(Assignee)

Comment 6

16 years ago
Will have to give this some thought. Need to be able to read/write a generic
margin setting, but also let them be global or unique to each window.

One solution is: If the app is using "global" PrintSettings, is to have it save
out just the margin settings when the PrintSettingsService shutdown.

Comment 7

16 years ago
The description of this bug sounds as if it must (also) invoke bug 150416 (0.8 >
0.5).
(Assignee)

Updated

16 years ago
Target Milestone: Future → mozilla1.1beta

Comment 8

16 years ago
*** Bug 163866 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
*** Bug 151214 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Duplicated bug 163866 was for W2K, changing OS -> All. 
OS: Linux → All
(Assignee)

Comment 11

16 years ago
I think this will soon be fixed by a different bug.
Target Milestone: mozilla1.1beta → mozilla1.2final
(Assignee)

Comment 12

16 years ago
fixed with check in to Bug 167894
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.