Improve help menu item labels in toolbox meatball menu

VERIFIED FIXED in Firefox 61

Status

defect
VERIFIED FIXED
Last year
Last year

People

(Reporter: jryans, Assigned: birtles)

Tracking

(Blocks 1 bug)

unspecified
Firefox 61
Dependency tree / graph

Firefox Tracking Flags

(firefox61 verified)

Details

User Story

"Documentation ..." should link to MDN dev tools landing page.

"Community ..." should link to discourse.

The ellipsis is required for marking the buttons as opening a new tab, following photon design guidelines.

Attachments

(1 attachment)

From Harald in bug 1444301:

::: devtools/client/locales/en-US/toolbox.properties:182
(Diff revision 3)
>  # The keyboard shortcut will be shown to the side of the label.
>  toolbox.meatballMenu.settings.label=Settings
>  
> +# LOCALIZATION NOTE (toolbox.meatballMenu.gettingStarted.label): This is the
> +# label for the Getting Started menu item.
> +toolbox.meatballMenu.gettingStarted.label=Getting started

As the page isn't about Getting Started but just documentation the naming does not make full sense. Reviewing other tools, "Documentation" and "Release Notes" are typical Help entries.

::: devtools/client/locales/en-US/toolbox.properties:186
(Diff revision 3)
> +# label for the Getting Started menu item.
> +toolbox.meatballMenu.gettingStarted.label=Getting started
> +
> +# LOCALIZATION NOTE (toolbox.meatballMenu.giveFeedback.label): This is the label
> +# for the Give feedback menu item.
> +toolbox.meatballMenu.giveFeedback.label=Give feedback

"Community" might be more appropiate here, as all other feedback forms in Firefox lead to survey forms and are not about starting discussions.
Reporter

Updated

Last year
Blocks: 1444299
No longer depends on: 1444299
Reporter

Updated

Last year
Summary: Improve Help menu labels → Improve help menu item labels in toolbox meatball menu
Thanks Ryan and Harald - I agree that "Documentation" and "Community" are more accurate for those menu items.

(I think Getting Started and Give Feedback are more aspirational and reference webpages/workflows that we don't have yet, but maybe we will in the future :))
Assignee

Comment 2

Last year
Is "Community" the right label here? It seems quite abstract. How about "Get involved"? Or even "Discussion"?

Also, would "Help" be better than "Documentation"? Does "Documentation" sound a little academic/boring?
Yeah, I see what you mean about Community — even Get Involved seems a bit more aspirational than what our Discourse site is. I feel we need a more polished-looking version of this section of our github pages site: http://firefox-dev.tools/#getting-in-touch Maybe it's worth linking to this either way just because it's more broadly useful?

For me, "Help" makes me think of customer service contact forms or a database of FAQs, so I think I'd stay with Documentation for the MDN link.
Comment hidden (mozreview-request)
Assignee

Updated

Last year
Assignee: nobody → bbirtles
Status: NEW → ASSIGNED
Assignee

Comment 5

Last year
(In reply to Victoria Wang [:victoria] from comment #3)
> I feel we need a more
> polished-looking version of this section of our github pages site:
> http://firefox-dev.tools/#getting-in-touch Maybe it's worth linking to this
> either way just because it's more broadly useful?

We probably should have an HTTPS site before we link to it.
Assignee

Comment 6

Last year
For now I've just renamed the toolbar entries to:

* Documentation
* Get involved

but haven't changed where they link to.

Harald, Victoria, what do you think?
(In reply to Brian Birtles (:birtles, travelling 7~18 April) from comment #5)
> (In reply to Victoria Wang [:victoria] from comment #3)
> > I feel we need a more
> > polished-looking version of this section of our github pages site:
> > http://firefox-dev.tools/#getting-in-touch Maybe it's worth linking to this
> > either way just because it's more broadly useful?
> We probably should have an HTTPS site before we link to it.

Shyam (cc-ed) could help with this part, if we want to file a new bug…
(Or we could continue to wait for Github to integrate Lets Encrypt support for their gh-pages sites… 
Reporter

Comment 8

Last year
(In reply to Blake Winton (:bwinton) (:☕️) from comment #7)
> (In reply to Brian Birtles (:birtles, travelling 7~18 April) from comment #5)
> > (In reply to Victoria Wang [:victoria] from comment #3)
> > > I feel we need a more
> > > polished-looking version of this section of our github pages site:
> > > http://firefox-dev.tools/#getting-in-touch Maybe it's worth linking to this
> > > either way just because it's more broadly useful?
> > We probably should have an HTTPS site before we link to it.
> 
> Shyam (cc-ed) could help with this part, if we want to file a new bug…
> (Or we could continue to wait for Github to integrate Lets Encrypt support
> for their gh-pages sites…

This issue[1] anecdotally suggests there's a slow rollout of HTTPS support for custom domains.

It's also possible to use a free Cloudflare account to get HTTPS on a GitHub site, though it's only "flexible" meaning encrypted from client to CF but unencrypted to GH.

[1]: https://github.com/isaacs/github/issues/156
> Is "Community" the right label here? It seems quite abstract. How about "Get involved"? Or even "Discussion"?

There are many words for this and I would love to see at some point if users actually click through and discuss topics.

I am just leaning right now on the most honest and explicit option. The forum does not serve users well for quickly posting feedback (would be better served with a feedback form) or getting started as contributors (needs an engaging contributors landing page that is well maintained).

> Also, would "Help" be better than "Documentation"? Does "Documentation" sound a little academic/boring?

As above, Docs seems more direct (and used in other software).

---

Adding to the name changes, both links should be marked as opening in a new window with "…".
Reporter

Comment 10

Last year
Harald, Victoria, see comment 6 about the proposed change here.

(Personally, I am unsure about using "Get involved" for the Discourse page...  Historically we've used "Get involved" to mean "getting started docs for contributing", which today would either be something like http://firefox-dev.tools/ or http://docs.firefox-dev.tools/getting-started/)
Reporter

Updated

Last year
Flags: needinfo?(victoria)
Reporter

Comment 11

Last year
mozreview-review
Comment on attachment 8968142 [details]
Bug 1452290 - Update the labels in the DevTools meatball menu;

https://reviewboard.mozilla.org/r/236820/#review242710

::: devtools/client/locales/en-US/toolbox.properties:182
(Diff revision 1)
> -# label for the Getting Started menu item.
> -toolbox.meatballMenu.gettingStarted.label=Getting started
> -
> -# LOCALIZATION NOTE (toolbox.meatballMenu.giveFeedback.label): This is the label
> -# for the Give feedback menu item.
> -toolbox.meatballMenu.giveFeedback.label=Give feedback
> +# label for the Documentation menu item.
> +toolbox.meatballMenu.documentation.label=Documentation
> +
> +# LOCALIZATION NOTE (toolbox.meatballMenu.getInvolved.label): This is the label
> +# for the Get involved menu item.
> +toolbox.meatballMenu.getInvolved.label=Get involved

(Should we be using title case in our menu items?  It looks like DevTools _does not_ use title case, but Firefox and macOS _do_ use it...)
Brian, comment 9 is the current decision for naming. Please also add the "...".

I'll file a follow up bug for a getting involved entry.
Reporter

Comment 13

Last year
mozreview-review
Comment on attachment 8968142 [details]
Bug 1452290 - Update the labels in the DevTools meatball menu;

https://reviewboard.mozilla.org/r/236820/#review242720

Sounds like Harald has suggested some changes.
Attachment #8968142 - Flags: review?(jryans) → review-
User Story: (updated)
User Story: (updated)
Comment hidden (mozreview-request)
Reporter

Comment 15

Last year
mozreview-review
Comment on attachment 8968142 [details]
Bug 1452290 - Update the labels in the DevTools meatball menu;

https://reviewboard.mozilla.org/r/236820/#review242732
Attachment #8968142 - Flags: review?(jryans) → review+
Assignee

Comment 16

Last year
mozreview-review
Comment on attachment 8968142 [details]
Bug 1452290 - Update the labels in the DevTools meatball menu;

https://reviewboard.mozilla.org/r/236820/#review242734

::: devtools/client/framework/components/toolbox-toolbar.js:406
(Diff revision 2)
>      },
>    }));
>  
>    // Give feedback
>    menu.append(new MenuItem({
> -    id: "toolbox-meatball-menu-feedback",
> +    id: "toolbox-meatball-menu-get-involved",

(Oops, forgot to update this one.)
Comment hidden (mozreview-request)

Comment 18

Last year
Pushed by bbirtles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c89827f5b8eb
Update the labels in the DevTools meatball menu; r=jryans
(In reply to :Harald Kirschner :digitarald from comment #12)
> Brian, comment 9 is the current decision for naming. Please also add the
> "...".
> 
> I'll file a follow up bug for a getting involved entry.

Sounds good. For now, I can write a reply post to the currently pinned thread (https://discourse.mozilla.org/t/about-the-developer-tools-category/12921) with some of the links from the Get in Touch section of http://firefox-dev.tools/.
> Sounds good. For now, I can write a reply post to the currently pinned thread (https://discourse.mozilla.org/t/about-the-developer-tools-category/12921) with some of the links from the Get in Touch section of http://firefox-dev.tools/.

Sounds good. Might it make sense to unpin the current one and start from scratch with a note that we can edit and keep updated?
I filed bug 1454298 as follow up to tag the links for analytics.
(In reply to :Harald Kirschner :digitarald from comment #20)
> > Sounds good. For now, I can write a reply post to the currently pinned thread (https://discourse.mozilla.org/t/about-the-developer-tools-category/12921) with some of the links from the Get in Touch section of http://firefox-dev.tools/.
> 
> Sounds good. Might it make sense to unpin the current one and start from
> scratch with a note that we can edit and keep updated?

Oh yeah, even better, I'll do that instead.
Flags: needinfo?(victoria)
https://hg.mozilla.org/mozilla-central/rev/c89827f5b8eb
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
I have reproduced this issue using Firefox 61.0a1 (2018.04.06) on Ubuntu 14.04 x64.
I can confirm this issue is fixed, I verified using Firefox 61.0b10 on Win 10 x64, Ubuntu 14.04 x64 and Mac OS X 10.13.
Status: RESOLVED → VERIFIED

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.