Closed Bug 1452297 Opened 4 years ago Closed 4 years ago

[wpt-sync] Sync PR 10335 - Fix the unit test for affected tests

Categories

(Testing :: web-platform-tests, enhancement, P4)

enhancement

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 10335 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/w3c/web-platform-tests/pull/10335
Details from upstream follow.

Robert Ma <robertma@chromium.org> wrote:
>  Fix the unit test for affected tests
>  
>  The root cause is that we use the up-to-date manifest and rely on the
>  files on the head of master, so the test will fail whenever the file we
>  are asserting is renamed (which unfortunately happened at
>  bf17459a71ff4d1ea280bae54dd046ecf86e0628).
>  
>  This PR doesn't fix the root cause, but instead switches to a relatively
>  stable test file (`infrastructure/reftest-wait.html`). Hopefully this
>  will hold in the forseeable future.
>  
>  
>
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/196cbc3a695e
[wpt PR 10335] - Fix the unit test for affected tests, a=testonly
https://hg.mozilla.org/mozilla-central/rev/196cbc3a695e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.