Closed Bug 1452342 Opened 2 years ago Closed 2 years ago

Cursor doesn't appear while playing videos in fullscreen mode

Categories

(Toolkit :: XUL Widgets, defect)

61 Branch
Unspecified
All
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- verified

People

(Reporter: ssj2kite, Assigned: timdream)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180406220121

Steps to reproduce:

Go to any video file (only tested webm and mp4) and enter fullscreen mode.


Actual results:

The mouse cursor doesn't appear over the video content, but does appear over the overlay.


Expected results:

Cursor should appear over the video as well.  Mozregression pointed to bug #1449532.
Blocks: 1449532
Status: UNCONFIRMED → NEW
Component: Untriaged → XUL Widgets
Ever confirmed: true
Keywords: regression
Product: Firefox → Toolkit
I can confirm the problem.
Open any video from https://videos.cdn.mozilla.net/uploads/mozillaorg/
Go Fullscreen and then Move mouse
OS: Unspecified → All
Assignee: nobody → timdream
Status: NEW → ASSIGNED
I removed this line without restoring it. Sorry about that.

https://hg.mozilla.org/integration/autoland/rev/62e9d302879c#l5.244

I must have overlooked it because "force style resolution" two lines above is very catchy...
Comment on attachment 8966101 [details]
Bug 1452342 - Toggle cursor visibility correctly in video fullscreen mode

https://reviewboard.mozilla.org/r/234846/#review240478

r=me, sorry for missing this in the review...

::: toolkit/content/tests/widgets/test_videocontrols.html:382
(Diff revision 1)
> +add_task(async function ensure_fullscreen_cursor() {
> +  video.removeAttribute("mozNoDynamicControls");
> +  video.play();
> +  await waitForEvent("play");
> +
> +  synthesizeMouse(video, fullscreenButtonCenterX, fullscreenButtonCenterY, {});

What guarantees that the button will still be visible at this point? Won't the controls hide once the video starts playing?
Attachment #8966101 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8966101 [details]
Bug 1452342 - Toggle cursor visibility correctly in video fullscreen mode

https://reviewboard.mozilla.org/r/234846/#review240478

> What guarantees that the button will still be visible at this point? Won't the controls hide once the video starts playing?

Right. I've switched to `video.mozRequestFullScreen();` instead (with `full-screen-api.allow-trusted-requests-only` set to `false`).
Pushed by timdream@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ea27d33d3920
Toggle cursor visibility correctly in video fullscreen mode r=Gijs
https://hg.mozilla.org/mozilla-central/rev/ea27d33d3920
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Issue was reproduced on Nightly 61.0a1 from 2018-04-06 on Windows 10x64.
Confirming the fix with 61.0b12 on Windows 10x64, MacOS 10.13 and Ubuntu 14.04.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.