Closed Bug 1452351 Opened 3 years ago Closed 2 years ago

box shadow rendering issue

Categories

(Core :: Graphics: WebRender, defect, P1)

61 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: divinegod, Unassigned)

References

(Blocks 2 open bugs, )

Details

(Keywords: correctness, nightly-community)

Attachments

(2 files)

Attached file reduced test case.
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180406220121

Steps to reproduce:

Enabled web render in about:config (gfx.webrender.all true)
Restarted Firefox Nightly
Navigated to imdb.com


Actual results:

Saw a rendering issue along the left side of the page where a box shadow is meant to be
Scrolling makes the rendering issue disappear until reaching the bottom of the page


Expected results:

There should be a box shadow and not a rendering bug.
This image shows the rendering issue when scrolled to the top of the page
I've also created a codepen for this reduced testcase and in this case the only point it triggers is in full page mode: https://s.codepen.io/DivineGod/fullpage/geQLqa or https://codepen.io/DivineGod/full/geQLqa and not in normal editing mode for the codepen: https://codepen.io/DivineGod/pen/geQLqa
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
See Also: → 1452289
Mac only?
Priority: -- → P1
I only see this on Mac, and it's a regression from https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5110a382f6a073a9fa220936442125c961bc57af&tochange=8a988d1a6f23f900b90c7843e2c61db14a57e56c which means it's from one of these changes in upstream WR:

*   5cb71f0f Auto merge of #2499 - kvark:revert-fix, r=staktrace
|\
| * 9b069b7b Revert "textureSize() workaround for Angle/NV" for (somehow) causing text rendering issues on OSX.
* |   ce9c75b5 Auto merge of #2496 - jrmuizel:div, r=kvark
|\ \
| |/
|/|
| * fa1090c4 Do division and mod on unsigned integers
* |   7e459e81 Auto merge of #2497 - glennw:bi-opt, r=kvark
|\ \
| |/
|/|
| * 584459c6 Small optimization for the brush_image shader.
|/
* f3af2632 Auto merge of #2487 - glennw:bs-clip15, r=kvark
* 18cc8adb Handle minimal shadow rects with fractional offsets / sizes.
* 81f55acd Switch box-shadows to be a clip source instead of a picture.

Of these changesets, 81f55acd seems the most likely since it refers to box-shadows.

Also, interestingly, the issue goes away if I have the TreeStyleTabs sidebar open. Other sidebars (e.g. bookmarks/history) also affect the presence of the issue, but depending on what I'm hovering over on the sidebar.
Blocks: 1443807
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mac only, dropping it off the nightly blocker list.
No longer blocks: stage-wr-trains
Can't reproduce anymore on Mac. Should we close?
(In reply to Patrick Walton (:pcwalton) from comment #9)
> Can't reproduce anymore on Mac. Should we close?

Are you able to reproduce bug 1490883?
On the other hand, the worst part of this shadow regresson might have already been fixed for MacOS: bug 1472455 comment 10
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #10)
> (In reply to Patrick Walton (:pcwalton) from comment #9)
> > Can't reproduce anymore on Mac. Should we close?
> 
> Are you able to reproduce bug 1490883?

Commented over there, but I can't reproduce that bug. I'm on Mac.
I also am unable to reproduce this bug.

Looks fixed. Please reopen if not.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.