Closed Bug 1452432 Opened 2 years ago Closed 2 years ago

Reftest output for unexpected assertions broken

Categories

(Testing :: Reftest, defect)

defect
Not set

Tracking

(firefox-esr52 unaffected, firefox59 wontfix, firefox60 fixed, firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- wontfix
firefox60 --- fixed
firefox61 --- fixed

People

(Reporter: philor, Assigned: ahal)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1451966 ("Intermittent [u'svg/foreignObject-img-form-theme.html', u'==', u'svg/foreignObject-img-form-theme-ref.html'] | assertion count 1 is more than expected 0 assertions") is bad enough, but even more horrifying is the duplicate bug 1452044 ("Intermittent (u'svg/foreignObject-img-form-theme.html', u'==', u'svg/foreignObject-img-form-theme-ref.html') | assertion count 1 is more than expected 0 assertions") (where, if like me you're not seeing it, the difference is () versus []).

https://hg.mozilla.org/mozilla-central/rev/3585c6359fa2 seems to have touched output handling a bit, so I'll start my suspicions with bug 1353461
Made the mistake of reading this on the weekend. Better needinfo myself so I don't forget to take a look on Monday.
Flags: needinfo?(ahalberstadt)
I'm fairly sure this wasn't caused by bug 1353461, but I found the fix, so not going to bother trying to find the actual culprit (assuming this is even a regression).
Assignee: nobody → ahalberstadt
No longer blocks: 1353461
Status: NEW → ASSIGNED
Flags: needinfo?(ahalberstadt)
Comment on attachment 8966262 [details]
Bug 1452432 - Convert 'test' field to a string in assertionCount StructuredLog.jsm messages,

https://reviewboard.mozilla.org/r/235012/#review240660
Attachment #8966262 - Flags: review?(gbrown) → review+
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e4c7821c157
Convert 'test' field to a string in assertionCount StructuredLog.jsm messages, r=gbrown
Ah, my mistake: looks like the regression, more like 6 months old, came from fixing the way we used to report an assertion count failure in, e.g., svg/foreignObject-img-form-theme.html == svg/foreignObject-img-form-theme-ref.html, as just "svg/foreignObject-img-form-theme-ref.html | assertion count..." without mentioning the test filename, only the reference filename.
https://hg.mozilla.org/mozilla-central/rev/1e4c7821c157
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.