Closed Bug 145247 Opened 18 years ago Closed 17 years ago

microsoft.com - JavaScript "Type mismatch" on line 335; doesn't occur using MSIE

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: torrafy, Assigned: doronr)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

The "table of contents" frame on the right contains: "Microsoft JScript runtime
error '800a000d' Type mismatch /library/shared/deeptree/asp/deeptreeDL.inc, line 335
This is instead of containing the table of contents.
The same URL in MSIE works fine. (Maybe its a micro$oft thing ;-)
Other pages on the MSDN site have TOCs that work/display fine.

Reproducible: Always
Steps to Reproduce:
1.Copy the URL to the clipboard
2.Open a new Mozilla window
3.Paste the URL into the Address box
4.Press return!

Actual Results:  Page displayed but left hand frame contained a JScript error
message.

Expected Results:  The left hand frame should have contained the MSDN table of
contents open at the page I was viewing ("Testing applications with AppVerifier")

2KSP2, IE6 works OK
Note typo above: the Table of Contents is in the left frame, not right.
Confirming problem with Mozilla trunk 20020514xx WinNT, Linux.
OS: Win ---> All.

This looks like a clear Evangelism bug. I'm getting no errors in the
JavaScript Console. I tried unsuccessfully to find line 335 in that file.
I was also unable to get the JavaScript Debugger to shed light on things.

I did make an interesting discovery: if you strip the parameters
from the given URL, and only use this part of it:

         http://msdn.microsoft.com/library/default.asp

then the same table of contents appears in Mozilla as does in IE.
So the problem has something to do with the URL parameters, which
apparently determine what HTML to present in the right-hand frame.
With no parameters included, we get the "Welcome to the MSDN Library"
page in the right-hand frame. With the parameters included, we get
"Testing Applications with AppVerifier" in the right-hand frame.


Note the following function is the frameset onLoad handler for
http://msdn.microsoft.com/library/default.asp:

  function InitSync()
  {
      if( "object" == typeof( top.deeptree ) && 
          "unknown" == typeof( top.deeptree.Sync ) )
      {
        top.deeptree.Sync();
      }
  }


I tested the first logical condition after loading the page:

          javascript: alert(typeof(top.deeptree )) 

                   IE6            Moz
                'object'       undefined


In the IE6 case, we can also try the second condition:

          javascript: alert(typeof(top.deeptree.Sync )) 

                   IE6          
                'unknown'     


So in IE6, both logical conditions are met. When you load the full URL
in IE6, with the URL parameters included, the Table of Contents in the
left frame is synchronized with the topic shown in the right frame.
In our case, the right frame shows "Testing Applications with AppVerifier",
so the table of contents in the left frame is opened at that chapter.

Perhaps this part of the site is what is malfunctioning when Mozilla
loads the URL with parameters. The site doesn't do the synchronization,
because in the onLoad handler for the frameset, the logical conditions
are not met (see above).

So perhaps this causes trouble later on in their code, when things
they expect to be defined are undefined instead. Just a guess -
Assignee: rogerl → doron
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → US General
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: pschwartau → zach
Version: other → unspecified
cc'ing bclary on this -
This error does not appear in other articles linked to from that page. the .inc
file that is causing the error is happening server side in their api foo. 
Blocks: MS
->evang500
Keywords: evang500
Summary: JScript "Type mismatch" on line 335; doesn't occur using MSIE → microsoft.com - JavaScript "Type mismatch" on line 335; doesn't occur using MSIE
nav frame looks good to me in Moz OSX, no script errors. retest?
looks ok to me in trunk and commericial builds.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.