Intermittent browser/components/extensions/test/browser/test-oop-extensions/browser_ext_incognito_popup.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/browser.xul]

REOPENED
Unassigned

Status

defect
P5
normal
REOPENED
a year ago
15 days ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

unspecified
mozilla63
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox63 fixed)

Details

(Whiteboard: [retriggered])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=172554862&repo=try

https://queue.taskcluster.net/v1/task/d4ZQ30W5TNqhopKFWw0j2w/runs/0/artifacts/public/logs/live_backing.log

Seen for a central-as-beta simulation. Reproduces frequently.

This also failed when it landed earlier: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=f5d571a4cc16a447b38f29f499416293e8044342&selectedJob=172256043

18:45:03     INFO -  TEST-INFO | Main app process: exit 0
18:45:03    ERROR -  926 ERROR TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_incognito_popup.js | leaked 1 window(s) until shutdown [url = chrome://browser/content/browser.xul]
18:45:03    ERROR -  927 ERROR TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_incognito_popup.js | leaked 1 window(s) until shutdown [url = about:blank]
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Blocks: 1460738
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Updated

10 months ago
Product: Toolkit → WebExtensions
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
I see this coming from an inbound merge:
https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=12f49235dfd8d8b7330bf6e722ffdc122752ec0d

Ideally you should be able to retrigger on inbound in that range and find the root cause.
Flags: needinfo?(jmaher) → needinfo?(ebalazs)
oh nice, Bug 1443590 looks to be the culprit, :dmajor, could you look at this?
Blocks: 1443590
Flags: needinfo?(jmaher) → needinfo?(dmajor)
Changing compilers probably altered the timing characteristics of the code in a way that exposed an existing latent issue.

In terms of actually root-causing it, I'm afraid I don't have the subject-matter experience to investigate this at any reasonable speed. A DOM or Memshrink expert is likely to have better results.
Flags: needinfo?(dmajor)
Comment hidden (Intermittent Failures Robot)
jmaher: Do we have to ni someone else here? (Comment 19)
Thank you.
Flags: needinfo?(jmaher)
:ddurst, I see you are the triage owner for the component this test is associated with. In comment 18, we tracked this down to a compiler change- with the current rate of failures this test will be disabled soon, is it possible you could look into this test and see if there is something we can do to make it more reliable?
Flags: needinfo?(jmaher) → needinfo?(ddurst)
Comment hidden (mozreview-request)

Comment 25

9 months ago
mozreview-review
Comment on attachment 8993559 [details]
Bug 1452514: Correctly handle a browser window closing before its popups do.

https://reviewboard.mozilla.org/r/258258/#review265404
Attachment #8993559 - Flags: review?(mixedpuppy) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/f09c12fc7f40945e4751818ef011fe800097e6e7
Bug 1452514: Correctly handle a browser window closing before its popups do. r=mixedpuppy

Comment 27

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f09c12fc7f40
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee: nobody → kmaglione+bmo
Comment hidden (Intermittent Failures Robot)

Updated

9 months ago
Flags: qe-verify-

Comment 29

9 months ago
We are trying to build a tool to automatically classify intermittent failures, which would provide a starting point for fixing the bug, reducing the manual work for the developers.
We are collecting some feedback on the results, to see if they’re good enough and where we need to improve.
    
For this bug, the tool says that the intermittent failure is most likely a:
Test Order Dependency: This includes test failures in which one or multiple test(s) have not cleaned up after itself or require a certain state to be created/set before starting to run. Also, this includes test failures in which a test is started while another one is still running, and both are accessing/requiring the same state/resource. Please check whether there are clean-up or start-up dependencies between the test cases.


Once you’re done investigating and/or fixing the bug, could you tell me:
- Did the tool correctly recognize the type of intermittent failure?
- Did the information from the tool help your analysis, the bug fixing process, or anything in the process? (please also let us know how the tool was useful and/or what would improve the tool's usefulness for you)

Updated

9 months ago
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(ddurst)
Comment hidden (Intermittent Failures Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I'm confused. If this was resolved, then this should be fixed and a new bug opened, no?
Assignee: kmaglione+bmo → nobody
Flags: needinfo?(aciure)
Flags: needinfo?(kmaglione+bmo)
That's the standard flow yes, however I don't remember what the circumstances were in that case.
Flags: needinfo?(aciure)
Blocks: webext-incognito
No longer blocks: 1460738
No longer blocks: webext-incognito
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.