Closed Bug 1452612 Opened 5 years ago Closed 4 years ago

mouse cursor is 'ew-resize' over checkbox in Rules view after changing splitter

Categories

(DevTools :: Inspector, defect, P2)

60 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1451683

People

(Reporter: nachtigall, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. Open Inspector
2. Move splitter between Inspector and Rules view a bit to left (this makes the bug happen!)
3. Move mouse over any of the rules' checkboxes in Rules view

AR:
Mouse cursor is 'ew-resize' like if it would be over the splitter.

ER:
Mouse cursor is default (arrow) over checkbox.

See attached Screencast GIF.
Mozregression says:
11:17.03 INFO: Last good revision: ff4c0d600d07c9a5e0fe503a326db767962ea052
11:17.03 INFO: First bad revision: d17b9126dca6bb1f04a9bc454367159c7c10c861
11:17.03 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ff4c0d600d07c9a5e0fe503a326db767962ea052&tochange=d17b9126dca6bb1f04a9bc454367159c7c10c861



So setting as blocking bug 1420130 and NI'ing Mike.
Flags: needinfo?(mratcliffe)
Blocks: 1420130
Has Regression Range: --- → yes
Has STR: --- → yes
So the removal of the React Monkeypatch has broken this.

This is caused by XUL handling events differently than HTML elements and will be fixed by bug 1342297.
Depends on: 1342297
Flags: needinfo?(mratcliffe)
Actually a duplicate of bug 1451683 which has been fixed already.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1451683
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.