Move right-click selection from "enterSelection" to its own bucket

RESOLVED FIXED in Firefox 61

Status

()

defect
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: mak, Assigned: mak)

Tracking

55 Branch
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Assignee

Updated

a year ago
Duplicate of this bug: 1449488

Comment 3

a year ago
mozreview-review
Comment on attachment 8967734 [details]
Bug 1452890 - Move address bar right-click selection from 'enterSelection' to its own histogram bucket.

https://reviewboard.mozilla.org/r/236452/#review242354

Wow, good catch...  Do you think "right-click" would be a better label for this userSelectionBehavior?  To me, "click" means a left-click, and that's a little confusing here.  Or maybe even "enter-after-right-click", since the enter key is still involved -- the selection is not triggered by a right-click alone.
Attachment #8967734 - Flags: review?(adw) → review+
Assignee

Comment 4

a year ago
(In reply to Drew Willcoxon :adw from comment #3)
> Wow, good catch...  Do you think "right-click" would be a better label for
> this userSelectionBehavior?  To me, "click" means a left-click, and that's a
> little confusing here.  Or maybe even "enter-after-right-click", since the
> enter key is still involved -- the selection is not triggered by a
> right-click alone.

Imo, it doesn't matter yet, what we care is whether the user selected with the mouse or the keyboard, and this case covers a negligible (<0.5%) percentage.
In the future, if we introduce a contextual menu, we may want to measure its usage, but for now it's a bit pointless.
Agree about negligibility, just think the label could be clearer.  I leave it up to you
Assignee

Comment 6

a year ago
ok, fair enough, it's not particularly complicate, it will probably be a very tiny bucket.
Summary: Move right-click selection from "enterSelection" to the "click" bucket → Move right-click selection from "enterSelection" to its own bucket
Assignee

Comment 7

a year ago
I was about to use rightClickEnterSelection, but histogram labels have a 20 chars limit, so I guess I'll just use rightClickEnter
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 10

a year ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/eb41147ad8b7
Move address bar right-click selection from 'enterSelection' to its own histogram bucket. r=adw
https://hg.mozilla.org/mozilla-central/rev/eb41147ad8b7
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Hey Marco, sorry for the fly-by: please note that adding new labels to categorical histograms isn't supported on the pipeline side: see https://firefox-source-docs.mozilla.org/toolkit/components/telemetry/telemetry/collection/histograms.html#categorical
Flags: needinfo?(mak77)
Assignee

Comment 13

a year ago
Hi, well we actually already added categories here before this change...

I think the documentation is unclear, at
https://firefox-source-docs.mozilla.org/toolkit/components/telemetry/telemetry/collection/histograms.html#changing-a-histogram
it states:
"The one exception is categorical histograms which can only be changed by adding labels, and only until it reaches 50 labels."
which documentation is right?

Fwiw, I'd have no problem at renaming this histogram and letting the old one die...
Flags: needinfo?(mak77) → needinfo?(alessio.placitelli)
Turns out I was wrong :) This can be done up to 50 labels without any problòem.
Flags: needinfo?(alessio.placitelli)
You need to log in before you can comment on or make changes to this bug.