Closed Bug 14529 Opened 21 years ago Closed 20 years ago

Send notifications based on union of notifiers before and after change.

Categories

(Bugzilla :: Bugzilla-General, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
Bugzilla old

People

(Reporter: CodeMachine, Assigned: terry)

References

Details

It seems that notifications won't get sent to the person who used to have the
bug assigned to them if you change the assignment.  Shouldn't they know if you
unassign them?

Hence I recommend that you should evaluate the notifiers both in the context of
before and after the change and take the union of the sets.
*** Bug 14897 has been marked as a duplicate of this bug. ***
From 14897: "Therefore bugs can silently disappear off your plate without you
being able to respond or fix it if it is an error. Or worse, malicious."

This has a serious potential for mischief.
Another option is to automatically add old notifiers to the CC list.  This is
probably not desired for QA contacts, but it might be for assignee.  The
possible exception to the latter is component owners, who might not want the
spam.  Hence, it might be a preference.  Either way, this would only be feasible
after bug #7345 was implemented to avoid excessive CC spam, and probably will,
for the reasons above, not be able to replace this report.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I fixed this a few days ago.  Mail will get sent to the old CC, assigned-to, and
qa-contact people showing that they are being removed.
per Terry, auto-verifying any resolved bug that hasn't been touched since before 
2.10 was released.
Status: RESOLVED → VERIFIED
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.