Intermittent devtools/client/inspector/test/browser_inspector_highlighter-cssshape_04.js | Test timed out -

RESOLVED FIXED in Firefox 61

Status

defect
P5
normal
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: intermittent-bug-filer, Assigned: rcaliman)

Tracking

({intermittent-failure})

unspecified
Firefox 61

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
treeherder
Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=172852248&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/DkkbsXPpSZiGkvzYPiHO1g/runs/0/artifacts/public/logs/live_backing.log

05:34:05     INFO - TEST-PASS | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_04.js | Point successfully removed - 
05:34:05     INFO - Turn off shapes highlighter for #polygon
05:34:05     INFO - Toggle shapes highlighter off for clip-path on #polygon
05:34:05     INFO - Turn on shapes highlighter for #circle
05:34:05     INFO - Selecting the node for '#circle'
05:34:05     INFO - Toggle shapes highlighter on for clip-path on #circle
05:34:05     INFO - Moving circle center
05:34:05     INFO - Buffered messages finished
05:34:05     INFO - TEST-UNEXPECTED-FAIL | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_04.js | Test timed out - 
05:34:05     INFO - Removing tab.
05:34:05     INFO - Waiting for event: 'TabClose' on [object XULElement].
05:34:05     INFO - Got event: 'TabClose' on [object XULElement].
05:34:05     INFO - Tab removed and finished closing
05:34:05     INFO - GECKO(1707) | MEMORY STAT | vsize 4584MB | residentFast 545MB | heapAllocated 106MB
05:34:05     INFO - TEST-OK | devtools/client/inspector/test/browser_inspector_highlighter-cssshape_04.js | took 45195ms
This failure has 24 occurrences in the last 2 days.
The failure started as a TV failure from https://hg.mozilla.org/integration/mozilla-inbound/rev/b9f53df7f40072fc40126914778d82ab4a6c4b3a and as dt4 from https://hg.mozilla.org/integration/autoland/rev/1c0e8f1f335fe13adbe1d621a64d0114814bd115

:gl , can you please take a look?
Flags: needinfo?(gl)
Comment hidden (Intermittent Failures Robot)
(Assignee)

Comment 3

a year ago
This is introduced by a change I made. Not sure of the root cause, but I'll investigate.
Flags: needinfo?(gl) → needinfo?(rcaliman)
Comment hidden (Intermittent Failures Robot)
(Assignee)

Updated

a year ago
Attachment #8969207 - Flags: review?(rcaliman)
(Assignee)

Comment 6

a year ago
Comment on attachment 8969207 [details]
Bug 1452986 - Fix intermittent timeout for test devtools/client/inspector/test/browser_inspector_highlighter-cssshape_04.js.

Fix for intermittent looks stable in try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fce82312189f033621fdad51f4ea2b0a771f6618&selectedJob=174486527
Flags: needinfo?(rcaliman)
Attachment #8969207 - Flags: review?(rcaliman)
Attachment #8969207 - Flags: review+
(Assignee)

Updated

a year ago
Assignee: nobody → rcaliman
As discussed with Razvan, since this is a minor fix for an intermittent it's ok to R+ it himself.
(Assignee)

Updated

a year ago
Keywords: checkin-needed

Comment 8

a year ago
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7d9c2c643136
Fix intermittent timeout for test devtools/client/inspector/test/browser_inspector_highlighter-cssshape_04.js on a CLOSED TREE. r=me
Keywords: checkin-needed

Comment 9

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7d9c2c643136
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment hidden (Intermittent Failures Robot)
(Assignee)

Updated

a year ago
Blocks: 1242029
(Assignee)

Updated

a year ago
No longer blocks: 1242029

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.