Animated properties: background-color can be selected

VERIFIED FIXED in Firefox 61

Status

defect
VERIFIED FIXED
Last year
Last year

People

(Reporter: gyula.palko, Assigned: daisuke)

Tracking

(Blocks 2 bugs, {regression})

61 Branch
Firefox 61
All
Unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61 verified)

Details

Attachments

(3 attachments)

[Environment:]
Windows 8.1, Windows 10, Mac OSX 10.13.2
Nightly 61.0a1 2018-04-04

[Steps:]
1. Open Firefox Nightly and load https://rawgit.com/dadaa/3b73f847427025b51ba1ab7333013d0c/raw/77f3f0bb884875a179c3407f73bf8a8dd54751c9/doc_simple_animation.html.
2. Press F12.
3. Select Inspector.
4. Select Animation tab.
5. Select div.ball.longhand
6. On Animated properties section hover over background-color property
[Actual Result:]
 background-color is highlighted, the user could expect to be clickable
 -see attached screenshot

[Expected Result:]
 background-color property should not be highlighted
Hardware: Unspecified → All
Summary: Animated properties: backround-color can be selected → Animated properties: background-color can be selected
I'm sorry for making you to confuse.
This border line does not express selectable. I intended to express easing hint.

Although the previous animation inspector does not show anything at all, the sign is useful to understand which area we are focusing, I think.
So, I'd like to change the expression for the hint as like this attachment.

Thanks.
Assignee: nobody → dakatsuka
Comment on attachment 8967014 [details]
Bug 1453239: Change the expression of easing hint of properties which animate as color.

https://reviewboard.mozilla.org/r/235680/#review242510
Attachment #8967014 - Flags: review?(gl) → review+
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ed4a62159f8a
Change the expression of easing hint of properties which animate as color. r=gl
https://hg.mozilla.org/mozilla-central/rev/ed4a62159f8a
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
I have reproduced this bug with Nightly 61.0a1 (2018-04-11) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with latest Nightly !

Build   ID    20180423100754
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

[bugday-20180418]
I have verified this bug on Windows 10, Windows 8 and Mac OS 10.12.6. It has been fixed.
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.