taskgraph: Make treescript tasks support esr60

RESOLVED FIXED

Status

enhancement
RESOLVED FIXED
Last year
Last year

People

(Reporter: jlorenzo, Assigned: jlorenzo)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 fixed, firefox61 fixed)

Details

Attachments

(1 attachment)

Generating a taskgraph with esr60 configs[1] leads to some discrepancies. The things I've noticed are:

* release-version-bump-firefox
  * Bad version in tags. This might be caused bug This might be caused by bug 1453261 comment 1
  * worker type is fine.

There are probably other issues I didn't see.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1434889#c4
Hello Callek! 60.0esr goes to build on April 30th. Would you feel comfortable looking into this bug by then?
Flags: needinfo?(bugspam.Callek)
(In reply to Johan Lorenzo [:jlorenzo] - On PTO - Back on April 16th from comment #0)
> Generating a taskgraph with esr60 configs[1] leads to some discrepancies.
> The things I've noticed are:
> 
> * release-version-bump-firefox
>   * Bad version in tags. This might be caused bug This might be caused by
> bug 1453261 comment 1
>   * worker type is fine.
> 
> There are probably other issues I didn't see.
> 
> [1] https://bugzilla.mozilla.org/show_bug.cgi?id=1434889#c4

I *think* we want version to be 60.0 but version_display to be 60.0esr  I'm not 100% sure here...

Pretty sure the main version file needs to be 60.0/60.1 etc but we want version_display to read esr due to https://bugzilla.mozilla.org/show_bug.cgi?id=1432737
Flags: needinfo?(bugspam.Callek)
See Also: → 1432737
So looking closer at this, I *think* we want to use version_display for tags at https://dxr.mozilla.org/mozilla-central/source/taskcluster/taskgraph/transforms/task.py#1135

This certainly relates to a need to set 'esr' to the version_display value ala Bug 1432737 (at initial uplift time). Ship it, as today, would continue to just set 'version': '60.1' and so on.

We then also need to do https://github.com/mozilla-releng/treescript/issues/16 otherwise treescript will fail to update the version_display.

n-i to Sylvestre to be aware of it.
Flags: needinfo?(sledru)
Sounds right, do you think you could finish that in time for the 60.0esr release?
merci!
Flags: needinfo?(sledru) → needinfo?(bugspam.Callek)
(In reply to Johan Lorenzo [:jlorenzo] from comment #0)
> * release-version-bump-firefox
>   * Bad version in tags. This might be caused bug This might be caused by
> bug 1453261 comment 1

With the correct data discussed in bug 1453261 comment 4, the tags in payload now look sane "FIREFOX_60_0esr_BUILD1", "FIREFOX_60_0esr_RELEASE". Please note I didn't have to update version_display.txt. For more information, please refer to the first paragraph of bug 1453261 comment 5.

Callek pointed the file list was also wrong. Here's a fix below.
Comment on attachment 8968181 [details]
Bug 1453275 - Fix file list to bump in esr60

https://reviewboard.mozilla.org/r/236852/#review242640

r+ but since this code rides trains and won't be used on esr52 anyway, might as well just s/esr52/esr60/ in here?
Attachment #8968181 - Flags: review?(bugspam.Callek) → review+
Pushed by Callek@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/b3a530c29fbe
Fix file list to bump in esr60 r=Callek
Flags: needinfo?(bugspam.Callek)
https://hg.mozilla.org/mozilla-central/rev/b3a530c29fbe
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Assignee: nobody → jlorenzo
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f05c85e615c8
Fix file list to bump in esr60 r=Callek
You need to log in before you can comment on or make changes to this bug.