Closed Bug 1453432 Opened 2 years ago Closed 2 years ago

Discarding a tab clears its favicon

Categories

(WebExtensions :: Frontend, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1450382

People

(Reporter: mstriemer, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When you discard a tab with browser.tabs.discard() then its favicon is removed from the tab strip. It would look better if the favicon was maintained so its easier to find the tab again later.
Using Discard Tab I am not able to reproduce this.

https://addons.mozilla.org/en-US/firefox/addon/discard-tab/?src=search
Flags: needinfo?(mstriemer)
Attached image discard-favicon.mov.gif
It seems to be lost for Bugzilla and Facebook, but not for AMO. I'm not sure what the difference is though.
Flags: needinfo?(mstriemer)
Similar bugs:
Bug 1427822
Bug 1451799
Shane,

As Robert points out, there are a few other reported issues with tabs.discard and favicons.  https://bugzilla.mozilla.org/show_bug.cgi?id=1427822 is one of the main ones and already has 200+ votes which I would think shows a fair amount of impact considering there probably isn't a very large number of people using tabs.discard just yet.

I added a comment to that issue (https://bugzilla.mozilla.org/show_bug.cgi?id=1427822#c1) and was able to reproduce the issue with a clean profile after a few restarts.  Once a tab gets into this state, it doesn't seem to be able to use tabs.discard without losing the favicon. (Screenshot links in the comment) [favicon always loads properly when activating the tab]

I also zipped up that test profile and could provide\attach it if that helps. (8MB)

Sincerely,
Mike
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1450382
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.