Port bug 1452019 to TB: Fix tab_selected when lwt-image attribute is not set

RESOLVED FIXED in Thunderbird 61.0

Status

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 61.0

Thunderbird Tracking Flags

(thunderbird60 fixed, thunderbird61 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

Last year
Port the change from bug 1452019 to TB.
Assignee

Comment 1

Last year
Unfortunately in bug 1452019 there is no explanation what exactly regressed. But it must be that not all theme colours are applied. And this is a small change which should be safe also to uplift. The regressing bug 1439134 is in TB 60.

This patch is a direct port of https://hg.mozilla.org/mozilla-central/rev/43742a3a7677 and with normal LW-themes and my WX-themes you should see no difference.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8967173 - Flags: review?(jorgk)
Attachment #8967173 - Flags: approval-comm-beta?

Comment 2

Last year
Comment on attachment 8967173 [details] [diff] [review]
tab_selected.patch

Funny you haven't noticed the difference. In your test WX theme you have
      "tab_selected": "#ff0",
      "toolbar": "#0f0",
Now the selected tab is yellow, before it had the colour of the toolbar and was green.
Attachment #8967173 - Flags: review?(jorgk)
Attachment #8967173 - Flags: review+
Attachment #8967173 - Flags: approval-comm-beta?
Attachment #8967173 - Flags: approval-comm-beta+

Comment 3

Last year
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/cc738342cb1c
Port bug 1452019 to TB: Fix tab_selected when lwt-image attribute is not set. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED

Updated

Last year
Target Milestone: --- → Thunderbird 61.0
Assignee

Comment 4

Last year
(In reply to Jorg K (GMT+1) from comment #2)
> Comment on attachment 8967173 [details] [diff] [review]
> tab_selected.patch
> 
> Funny you haven't noticed the difference. In your test WX theme you have
>       "tab_selected": "#ff0",
>       "toolbar": "#0f0",
> Now the selected tab is yellow, before it had the colour of the toolbar and
> was green.

I haven't tested the funny theme, but all other. :-(

Comment 5

Last year
I have that permanently installed.
You need to log in before you can comment on or make changes to this bug.