Closed Bug 1453528 Opened 2 years ago Closed 2 years ago

Can't open tabs in the Synced Tabs panel

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 61
Tracking Status
firefox61 --- verified

People

(Reporter: eoger, Assigned: jkt)

References

Details

Attachments

(1 file)

Reproduced on macOS 10.13.3 using the 2018-04-11 nightly.

STR:
- Connect to Sync Account
- Open the Synced Tabs panel (Hamburger menu -> Library -> Synced Tabs)
- Click on a tab

Expected:
Selected tab opens.

Actual:
Nothing happens (nothing logged in the browser console either).

mozregression:
> 3:29.75 INFO: Last good revision: 70ab5d0f6da37783913e39857edf488ccfc2ab7b
> 3:29.75 INFO: First bad revision: de33fb39fa4878714120d06ce6a0c72179016be9
> 3:29.75 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=70ab5d0f6da37783913e39857edf488ccfc2ab7b&tochange=de33fb39fa4878714120d06ce6a0c72179016be9

This is the line that should open the tab:
[0] https://searchfox.org/mozilla-central/rev/4114ad2cfcbc511705c7865a4a34741812f9a2a9/browser/components/customizableui/CustomizableWidgets.jsm#747
Will look into tomorrow.
Flags: needinfo?(jkt)
See Also: → 1453538
Assignee: nobody → jkt
Flags: needinfo?(jkt)
Hopefully this should solve Bug 1453538 at the same time (it was easier to fix and test this way anyway).
Comment on attachment 8967438 [details]
Bug 1453528 - Fix opening of synced tabs with correct principal.

https://reviewboard.mozilla.org/r/236110/#review242056

Awesome, thank you!
Attachment #8967438 - Flags: review?(markh) → review+
Duplicate of this bug: 1453538
Pushed by jkingston@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fd4e48f2273c
Fix opening of synced tabs with correct principal. r=markh
https://hg.mozilla.org/mozilla-central/rev/fd4e48f2273c
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
I have reproduced this bug with Nightly 61.0a1 (2018-04-11) on Windows 10, 64 Bit!

This bug's fix is verified with latest Nightly!

Bulid ID   -  20180415220108
User Agent -  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
QA Whiteboard: [bugday-20180411]
(In reply to Mohammad Maruf Rahman from comment #8)
> I have reproduced this bug with Nightly 61.0a1 (2018-04-11) on Windows 10,
> 64 Bit!
> 
> This bug's fix is verified with latest Nightly!
> 
> Bulid ID   -  20180415220108
> User Agent -  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0)
> Gecko/20100101 Firefox/61.0

Thanks for verifying. Marking accordingly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.