Closed Bug 1453570 Opened 4 years ago Closed 4 years ago

Intermittent ccov browser/components/extensions/test/browser/test-oop-extensions/browser_ext_devtools_panel.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but onl

Categories

(WebExtensions :: Untriaged, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1368332

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: nbeleuzu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=173204586&repo=mozilla-central

https://queue.taskcluster.net/v1/task/N7KZWdQ2SQm75k76qC7I5A/runs/0/artifacts/public/logs/live_backing.log

This is almost perma-failing on Mozilla-Central (windows10-64-ccov debug) starting with rev 0528a414c2a8
https://hg.mozilla.org/mozilla-central/rev/0528a414c2a86dad0623779abde5301d37337934

04:45:48    ERROR -  410 INFO TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_devtools_panel.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -
04:45:48     INFO -  411 INFO TEST-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_devtools_panel.js | Assertion count 4 is greater than expected range 0-0 assertions. -
04:45:48     INFO -  GECKO(6688) | MEMORY STAT | vsize 2751MB | vsizeMaxContiguous 130625602MB | residentFast 683MB | heapAllocated 246MB
04:45:48     INFO -  412 INFO TEST-OK | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_devtools_panel.js | took 108412ms
Summary: Intermittent [Tier-2] browser/components/extensions/test/browser/test-oop-extensions/browser_ext_devtools_panel.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but onl → Intermittent ccov browser/components/extensions/test/browser/test-oop-extensions/browser_ext_devtools_panel.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but onl
This has started failing on coverage with this merge push from autoland https://goo.gl/x8xYPu and has a failure rate around a 50% since then. It is related to Bug 1368332 which is and old known issue but why started also almost perma-failing on coverage I couldn't figure it out. 
Looked for changes on that file on autoland integration branch but did not find anything relevant. 
Joel, could you help with this also? Thanks.
Flags: needinfo?(jmaher)
Cosmin- thanks for looking into this- this bug is another case where the test has moved from one chunk to another, in this case it was previously in  bc4 and then moved to bc7.  I see failures pretty consistently back a day earlier did a few retriggers on that, then going back even further (all the way to April 6th), I see failures, it was on the chunk bc5 earlier:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-searchStr=debug-mochitest-browser-chrome-e10s%20win%20ccov&fromchange=6792eee0c9c5d1cf0fa10244c55e21a31a98c120&tochange=d1db4d5030c827ada3c01ec9d2ab5d665de2cd59

that bug was filed as bug 1368332 and that has 91 failures in the last week (many on linux32)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jmaher)
Resolution: --- → DUPLICATE
Duplicate of bug: 1368332
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.