Adjust font sizes, spacing, and font weights on about:preferences#home

VERIFIED FIXED in Firefox 61

Status

()

enhancement
P1
normal
VERIFIED FIXED
Last year
Last year

People

(Reporter: k88hudson, Assigned: k88hudson)

Tracking

(Blocks 1 bug)

unspecified
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 verified)

Details

Attachments

(2 attachments)

Assignee

Description

Last year
The content section of the about:preferences#home needs some adjustments according to abenson
Assignee

Updated

Last year
Assignee: nobody → khudson
Blocks: 1432589
Severity: normal → enhancement
Iteration: --- → 61.3 - Apr 23
Priority: -- → P1
Assignee

Updated

Last year
Attachment #8967496 - Flags: review?(edilee)

Comment 3

Last year
mozreview-review
Comment on attachment 8967496 [details]
Bug 1453761 - Adjust font sizes, spacing, and font weights on about:preferences#home

https://reviewboard.mozilla.org/r/236154/#review241984

Potentially this patch would just add margin-top to #homepageAndNewWindowsOption and do the contents stuff from activity stream AboutPreferences css?

::: browser/components/preferences/in-content/home.xul:30
(Diff revision 1)
>              data-l10n-id="home-restore-defaults"
>              preference="pref.browser.homepage.disable_button.restore_default"/>
>    </hbox>
>    <description data-l10n-id="home-new-windows-tabs-description2" />
>  
> -  <groupbox>
> +  <vbox class="subGroup">

Does there need to be a matching change for "contents" sub group just above the checkboxes? Although I see that there's the 0.9em for every checkbox being added instead of the 20px. It's intended that these are different?

Alternatively, if this is just for the dropdowns, could just set the margin-top on #homepageAndNewWindowsOption

::: browser/themes/shared/incontentprefs/preferences.inc.css:319
(Diff revision 1)
> +  margin-top: 0.9em;
> +}
> +#homeContentsGroup [data-subcategory] > checkbox {
> +  font-weight: 600;
> +}
> +#homeContentsGroup [data-subcategory] > vbox menulist {

Do we want these closer to the code that generates the content:
https://searchfox.org/mozilla-central/source/browser/extensions/activity-stream/lib/AboutPreferences.jsm#49-56

or I suppose that one rule could just move to this file… The intent to have it in the jsm was that there wouldn't need to be a separate m-c change.
Comment hidden (mozreview-request)

Comment 5

Last year
mozreview-review
Comment on attachment 8967496 [details]
Bug 1453761 - Adjust font sizes, spacing, and font weights on about:preferences#home

https://reviewboard.mozilla.org/r/236154/#review242312
Attachment #8967496 - Flags: review?(edilee) → review+

Comment 6

Last year
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eb8002dda30c
Adjust font sizes, spacing, and font weights on about:preferences#home r=Mardak

Comment 7

Last year
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/24e4f972e86fe3e05e0fef94fbadd6bc156350e0
Bug 1453761 - Make font size of option descriptions larger (design r=abenson)

https://github.com/mozilla/activity-stream/commit/484c03c13314e750c0896ecfc41e157d9af1cdaa
Merge pull request #4088 from k88hudson/stylefixesprefs

Bug 1453761 - Make font size of option descriptions larger

Updated

Last year
Blocks: 1454074

Comment 8

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/eb8002dda30c
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
The issue is no longer reproducible on the latest Nightly 61.0a1 on Windows 10, Mac 10.12.6 and Arch Linux x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.