Closed Bug 1453804 Opened 3 years ago Closed 3 years ago

Sync password validation is never run.

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox61 --- fixed

People

(Reporter: tcsc, Assigned: tcsc)

References

Details

Attachments

(1 file)

This is just clown shoes, and it's my own fault, bug 1412332's patch is only halfway finished. As it is a) the `getValidator()` method is on the wrong class and there's no `validate()` method on the CollectionValidator.

Patch incoming, and this one has been more thoroughly manually tested. (I could have sworn I had done this with the last one, but I think I just looked at logging, or something instead of ensuring it made it to the telemetry ping).
Comment on attachment 8967553 [details]
Bug 1453804 - Ensure sync password validator will ever run

https://reviewboard.mozilla.org/r/236228/#review242046

It would be great if we could also get a test that ensures things work as expected - I see most password tests that use the validator construct the password validator manually - maybe one of them could go via the doctor instead?
Attachment #8967553 - Flags: review?(markh) → review+
Adding an automated test for this was easier than I thought it would be.
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8056a366eaba
Ensure sync password validator will ever run r=markh
https://hg.mozilla.org/mozilla-central/rev/8056a366eaba
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
You need to log in before you can comment on or make changes to this bug.