Closed Bug 1453884 Opened 3 years ago Closed 3 years ago

Rename LazyScript.{begin,end} to LazyScript.{sourceStart,sourceEnd}.

Categories

(Core :: JavaScript Engine, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: arai, Assigned: arai)

References

Details

Attachments

(1 file)

I believe JSScript.{sourceStart,sourceEnd} and LazyScript.{begin,end} are same data.
So it's better using the same name for them.
See Also: → 1344428
Just renamed them.  no functional changes.
Attachment #8968430 - Flags: review?(dteller)
Comment on attachment 8968430 [details] [diff] [review]
Rename LazyScript.{begin,end} to LazyScript.{sourceStart,sourceEnd}.

Review of attachment 8968430 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8968430 - Flags: review?(dteller) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/038b4d1d073af308be6aa92c2fa2c2e594ea2222
Bug 1453884 - Rename LazyScript.{begin,end} to LazyScript.{sourceStart,sourceEnd}. r=Yoric
https://hg.mozilla.org/mozilla-central/rev/038b4d1d073a
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.