Closing console sidebar with Escape key does not give focus back to the console input

RESOLVED FIXED in Firefox 61

Status

defect
P3
normal
RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Tracking

Trunk
Firefox 61

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(1 attachment)

**Steps to reproduce**
1. Navigate to `data:text/html,<meta charset=utf8><script>console.log({a: 1})</script>`
2. Open the webconsole
3. Right-click on `Object { a: 1}`, and select `Open in sidebar`
4. Hit the Escape key

**Expected results**

The sidebar closes and the console input gets focused

**Actual results**

The sidebar do close, but the focus isn't restored to the console input

---
Has STR: --- → yes
Priority: -- → P3
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Comment on attachment 8968128 [details]
Bug 1453894 - Give focus to console input when closing sidebar with Escape key; .

https://reviewboard.mozilla.org/r/236804/#review242548

Works for me, thanks Nicolas!
R+ assuming try is green
Honza
Attachment #8968128 - Flags: review?(odvarko) → review+

Comment 3

a year ago
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/212963ca6f2b
Give focus to console input when closing sidebar with Escape key; r=Honza.
https://hg.mozilla.org/mozilla-central/rev/212963ca6f2b
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.