Closed Bug 1453898 Opened 3 years ago Closed 3 years ago

Intermittent browser/components/preferences/in-content/tests/browser_fluent.js | {"value":null,"attrs":[{"name":"label","value":"4 (default)"}]} deepEqual {"value":null,"attrs":[{"name":"label","value":"4"}]} - JS frame

Categories

(Firefox :: Preferences, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: zbraniecki)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: ccoroiu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=173437706&repo=autoland

https://queue.taskcluster.net/v1/task/WyqSLFWzTfqVLW-8pZvMBw/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-13T06:29:07.075Z] 06:29:07     INFO - TEST-START | browser/components/preferences/in-content/tests/browser_fluent.js
[task 2018-04-13T06:29:07.205Z] 06:29:07     INFO - GECKO(7987) | ERROR 2018-04-13T06:29:07Z: webrender::display_list_flattener: Unknown pipeline used for iframe IframeDisplayItem { clip_id: Clip(4, PipelineId(1, 1)), pipeline_id: PipelineId(1, 10) }
[task 2018-04-13T06:29:07.229Z] 06:29:07     INFO - GECKO(7987) | ERROR 2018-04-13T06:29:07Z: webrender::display_list_flattener: Unknown pipeline used for iframe IframeDisplayItem { clip_id: Clip(4, PipelineId(1, 1)), pipeline_id: PipelineId(1, 10) }
[task 2018-04-13T06:29:08.061Z] 06:29:08     INFO - TEST-INFO | started process screentopng
[task 2018-04-13T06:29:08.899Z] 06:29:08     INFO - TEST-INFO | screentopng: exit 0
[task 2018-04-13T06:29:08.901Z] 06:29:08     INFO - Buffered messages logged at 06:29:07
[task 2018-04-13T06:29:08.902Z] 06:29:08     INFO - Entering test bound 
[task 2018-04-13T06:29:08.904Z] 06:29:08     INFO - Buffered messages finished
[task 2018-04-13T06:29:08.905Z] 06:29:08     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_fluent.js | {"value":null,"attrs":[{"name":"label","value":"4 (default)"}]} deepEqual {"value":null,"attrs":[{"name":"label","value":"4"}]} - JS frame :: chrome://mochitests/content/browser/browser/components/preferences/in-content/tests/browser_fluent.js :: <TOP_LEVEL> :: line 40
[task 2018-04-13T06:29:08.905Z] 06:29:08     INFO - Stack trace:
[task 2018-04-13T06:29:08.906Z] 06:29:08     INFO - chrome://mochitests/content/browser/browser/components/preferences/in-content/tests/browser_fluent.js:null:40
[task 2018-04-13T06:29:08.906Z] 06:29:08     INFO - Leaving test bound 
[task 2018-04-13T06:29:08.907Z] 06:29:08     INFO - GECKO(7987) | MEMORY STAT | vsize 2500MB | residentFast 579MB | heapAllocated 348MB
[task 2018-04-13T06:29:08.908Z] 06:29:08     INFO - TEST-OK | browser/components/preferences/in-content/tests/browser_fluent.js | took 1095ms
[task 2018-04-13T06:29:08.909Z] 06:29:08     INFO - checking window state
[task 2018-04-13T06:29:09.170Z] 06:29:09     INFO - GECKO(7987) | ERROR 2018-04-13T06:29:09Z: webrender::display_list_flattener: Unknown pipeline used for iframe IframeDisplayItem { clip_id: Clip(4, PipelineId(1, 1)), pipeline_id: PipelineId(1, 11) }
[task 2018-04-13T06:29:09.885Z] 06:29:09     INFO - GECKO(7987) | ERROR 2018-04-13T06:29:09Z: webrender::display_list_flattener: Unknown pipeline used for iframe IframeDisplayItem { clip_id: Clip(4, PipelineId(1, 1)), pipeline_id: PipelineId(1, 11) }
[task 2018-04-13T06:29:10.346Z] 06:29:10     INFO - GECKO(7987) | Completed ShutdownLeaks collections in process 8157
[task 2018-04-13T06:29:10.392Z] 06:29:10     INFO - GECKO(7987) | Completed ShutdownLeaks collections in process 8103
[task 2018-04-13T06:29:10.410Z] 06:29:10     INFO - GECKO(7987) | Completed ShutdownLeaks collections in process 8127
[task 2018-04-13T06:29:10.427Z] 06:29:10     INFO - GECKO(7987) | Completed ShutdownLeaks collections in process 8048
[task 2018-04-13T06:29:10.905Z] 06:29:10     INFO - GECKO(7987) | Completed ShutdownLeaks collections in process 7987
we may want to remove this test. It was originally serving us to verify that fluent works when we migrated the first string, but now with whole Prefs in Fluent we probably don't need it, and it tests the variable for default process count which may change?
This is hella-frequent. Removing sounds good.
Nevermind, the one I'm seeing on 60 was from a broken uplift.
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
I can't reproduce the intermittent, but my guess is that because this l10n-id is set from JS it's prone to racing. Before we remove the test, I'd like to give a try switching it to test against regular DOM l10n-id. I used this ID because it exposes:
 - attributes
 - message references
 - and is upstreamable to beta
Comment on attachment 8968611 [details]
Bug 1453898 - Change the l10n id used in browser_fluent mochitest.

https://reviewboard.mozilla.org/r/237308/#review243110


Code analysis found 1 defect in this patch:
 - 1 defect found by mozlint

You can run this analysis locally with:
 - `./mach lint path/to/file` (JS/Python)


If you see a problem in this automated review, please report it here: http://bit.ly/2y9N9Vx


::: browser/components/preferences/in-content/tests/browser_fluent.js:31
(Diff revision 1)
>    let doc = gBrowser.contentDocument;
>    let win = gBrowser.contentWindow;
>    await doc.l10n.ready;
>  
>    let processCountPref = win.Preferences.get("dom.ipc.processCount");
>    let defaultProcessCount = processCountPref.defaultValue;

Error: 'defaultprocesscount' is assigned a value but never used. [eslint: no-unused-vars]
gotcha Code Review Bot. I managed to push the linter fix before you complained! Joke's on you!
Comment on attachment 8968611 [details]
Bug 1453898 - Change the l10n id used in browser_fluent mochitest.

https://reviewboard.mozilla.org/r/237308/#review243702
Attachment #8968611 - Flags: review?(l10n) → review+
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9130155caf45
Change the l10n id used in browser_fluent mochitest. r=Pike
https://hg.mozilla.org/mozilla-central/rev/9130155caf45
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
You need to log in before you can comment on or make changes to this bug.