find in current page fails

RESOLVED DUPLICATE of bug 78928

Status

RESOLVED DUPLICATE of bug 78928
17 years ago
13 years ago

People

(Reporter: aeb, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051009

Start Mozilla under Linux 2.4.17, XFree86 Version 4.1.0, tvtwm.
Want to search for a word in the current page.
The Menu under Edit has a "Find in This Page" that looks appropriate.
Selecting it, or typing Ctrl-F, causes a popup window to appear
with "Find text"-window, "Find"-button, "Cancel"-button.
But the "Find"-button is greyed out, and it is impossible to type
in the "Find text"-window, only "Cancel" works.

Reproducible: Always
Steps to Reproduce:
1.see above
2.
3.

Actual Results:  see above

Expected Results:  It is fairly essential for a browser to be able to search
in the current page.

Comment 1

17 years ago
"TWM and descendants" have some focus problems - bug 78928.
See comment 38 and 40 there: Does setting DecorateTransients (and /or removing
NoTitleFocus) help?
And "What windowmanager are you using?" just to make sure that this is not a
wrong angle...

Comment 3

17 years ago
Resolving as dup of bug 78928.
Reporter mailed:
----
Find in Current Page works well under afterstep, ctwm, mwm,
icewm, fvwm2, fvwn95, xfwm. It fails under twm and tvtwm.

That "Find" is greyed out is correct - it is when nothing
has been typed yet in the "Find Text" field.
So, more precisely, the bug is that no caret appears in the
"Find Text" field, and that it is impossible to type there.

Normally I use Netscape 4, and it works fine with twm and tvtwm.


> "TWM and descendants" have some focus problems - bug 78928.
> See comment 38 and 40 there: Does setting DecorateTransients help?

Yes. If I add a line "DecorateTransients" to .twmrc then all is fine.

Andries

*** This bug has been marked as a duplicate of 78928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.