Quantum Lights theme is completely broken in today's nightly

VERIFIED FIXED in Firefox 61

Status

defect
VERIFIED FIXED
a year ago
10 months ago

People

(Reporter: mossop, Assigned: vivek3zero)

Tracking

({regression})

unspecified
mozilla61

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61+ verified, firefox63 verified)

Details

Attachments

(3 attachments)

Updating to today's nightly and with Quantum Lights theme applied the UI is just a bright white/gray colour, not the nice theme that Martell intended.
I can repro on Mac, but WFM on Windows 10.

Note that the Quantum Lights extension is temporarily unavailable in AMO:

https://twitter.com/mart3ll/status/981168333448912898
(Assignee)

Comment 3

a year ago
I can look into this. Can you share a screenshot of how it looks like on OSX currently, while I set up my macbook?
Flags: needinfo?(vivek3zero) → needinfo?(dtownsend)
Here is a screenshot of Quantum Lights on my Mac.
Here is a copy of the Quantum Lights xpi since the extension is temporarily unavailable on AMO.
(Reporter)

Updated

a year ago
Flags: needinfo?(dtownsend)
(Assignee)

Comment 6

a year ago
Issue was tracked down to https://searchfox.org/mozilla-central/source/toolkit/themes/osx/global/toolbar.css#10 in OSX.
Bug 1443561 has been backed out for now till a better fix can be written. Quantum lights should work as expected now.
(Reporter)

Comment 7

a year ago
This is working again now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Assignee: nobody → vivek3zero
Target Milestone: --- → mozilla61

Updated

10 months ago
Product: Toolkit → WebExtensions

Comment 8

10 months ago
Issue reproduced in Firefox 61.0a1 (20180413100443) on macOS 10.13.4.
Retested and verified on Firefox 61.0 (20180621125625) in Windows 10 64Bit and macOS 10.13.4.

Comment 9

10 months ago
Retested and verified on Firefox 61.0a1 (20180413220147) in Windows 10 64Bit and macOS 10.13.4.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.