If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Text between two IMG, floated left, is re-appended to document on ':hover'

RESOLVED DUPLICATE of bug 145224

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 145224
16 years ago
16 years ago

People

(Reporter: John Morrison, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
On http://classifieds.bayarea.com/bay/home/real_estate/rentals, when
you hover over the text "Advanced Search" another instance of the text
"Advanced Search" will appear in the page.

This does not occur on the branch, and did not occur in trunk mozilla
2002-05-10-08-trunk on win2k, so this is a recent change.

Simplified test case is:

<html>
<head>
<style>
  a:hover   { color:#cc0000; text-decoration:underline; }
  /* actually, 'a:hover {}' is sufficent to trigger the content appends */
</style>
</head>
<body>

<p>
  Each time that ':hover' is activated or deactivated (mouseover|mouseout),
  another bit of text "Advanced Search" will be added to what is initially
  shown below. Note that the two images below must be floated left for this
  bug to take affect.
</p>

<img src="http://www.mozilla.org/newlayout/l.gif"
     align="left" width="10" height="10">

<a href="whatever">Advanced Search</a>

<img src="http://www.mozilla.org/newlayout/l.gif"
     align="left" width="10" height="10">

</body>
</html>
(Reporter)

Comment 1

16 years ago
Created attachment 84140 [details]
simple test; anchor text between two IMG floated left, re-appended on :hover.
(Reporter)

Updated

16 years ago
Keywords: nsbeta1
Summary: Text between two IMG, floated left, is re-appended to docment on ':hover' → Text between two IMG, floated left, is re-appended to document on ':hover'

*** This bug has been marked as a duplicate of 145224 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.