Mousewheel doesn't scroll mail after chosing it

RESOLVED INVALID

Status

RESOLVED INVALID
17 years ago
14 years ago

People

(Reporter: boris, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'm using 1.0 RC2 for reading my mail. To make the mousewheel really useful, I
suggest activating the mail window, when the user choses an email with the left
mouse button for reading. This way one could click on the interesting mails and
scroll them using the mouse wheel. Currently the message list keeps the focus,
so the mouse wheel scrolls the message list, what I find very confusing and not
really helpful. At the moment I have to click on the message, then into the mail
window, scroll it, and back again on the next message.
I know there are already some open issues regarding "clicking" and "scrolling",
but I think changing the focus is easy to do and would surely be what most users
expect the MUA to do.

Comment 1

17 years ago
testing with a current trunk cvs build, Linux:
i don't have to click in the message field to scroll there
I select a msg in the list, then simply mouse over the message pane and
wheel-scroll - and it scrolls.  (gnome/sawfish)

Which WM and theme are you using?
(Reporter)

Comment 2

17 years ago
This works for me too (1.0RC2, with KDE 3.0).
But this is exactly what I don't like: moving the mouse up and down do activate
the message list window or the message window. Scrolling the message also
doesn't work if the mouse pointer is over the message header.
For browsing through a lot of messages I would really prefer to have my mouse
over the message list window, click on a new message and then have the message
text area automatically activated, so the text can be scrolled with the wheel.

Comment 3

17 years ago
in that case, this seems to work by design, and is not a bug.

Personally i prefer that the page i mousewheel over is the one that scrolls.
I also find it very convenient that i don't have to click in the pane to
"activate" it.

Comment 4

16 years ago
intended behaviour
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.