Closed Bug 1454317 Opened 2 years ago Closed Last year

Shape Path Editor icon shows wrong state when editing CSS property

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox62 verified)

VERIFIED FIXED
Firefox 62
Tracking Status
firefox62 --- verified

People

(Reporter: mbalfanz, Assigned: rcaliman)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached video icon-state.mp4
The shape path editor icon in the rules panel shows then wrong state after editing the CSS property directly.

STR:
1. Open the inspector and inspect an element with shape-outside applied
2. Activate the shape path editor by clicking on the icon. The icon will be blue
3. Click the CSS property in order to edit it
4. Unfocus the input field again

Expected result:
- The shape path editor and it's icon will still be activated

Actual result
- The shape path editor is still activated, but the icon shows a deactivated state
Assignee: nobody → rcaliman
Summary: Shape Path Editor icon get shows wrong state when editing CSS property → Shape Path Editor icon shows wrong state when editing CSS property
Duplicate of this bug: 1464401
Status: NEW → ASSIGNED
Please note that by following the steps from Comment 0 the highlights in the rule-view will also not work. Fore reference, please check the attached file.
Product: Firefox → DevTools
Comment on attachment 8986006 [details]
Bug 1454317 - Reference correct shape swatch element after editing value in rule view.

https://reviewboard.mozilla.org/r/251484/#review257742

::: devtools/client/shared/widgets/ShapesInContextEditor.js:249
(Diff revision 1)
>    }
>  
>    /**
> +  * Handler for "property-value-updated" event triggered by the Rule view.
> +  * Called after the shape value has been written to the element's style and the Rule
> +  * view updated. Triggers an event on HighlightersOverlay that is expected by

s/Triggers/Emits
Attachment #8986006 - Flags: review?(gl) → review+
Pushed by rcaliman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7c4f5978d9da
Reference correct shape swatch element after editing value in rule view. r=gl
https://hg.mozilla.org/mozilla-central/rev/7c4f5978d9da
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Hi guys , i retested this issue and it no longer occurs in version 62.0a1 (2018-06-19). I will Mark it Verified as Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.