Closed Bug 1454320 Opened 2 years ago Closed 2 years ago

Firefox doesn't render SVG symbols correctly

Categories

(Core :: SVG, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 353575

People

(Reporter: MekliCZ, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image Screenshot of the bug
Hi, I'm working on website (attached to this bug) and I'm using SVG Symbols there. The problem is that few symbols with linearGradient as background aren't rendered at all. When I change the fill attribute of the shape from url(#gradient) to solid color, it works. The same when I replace the SVG Shape link with the SVG code using devtools.
You've put the linearGradient tags inside symbols. Just move them outside and your site will work.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353575
You need to log in before you can comment on or make changes to this bug.