Closed Bug 1454346 Opened 2 years ago Closed 2 years ago

24.06% Resident Memory (linux64-qr) regression on push 2efe54944e8c (Fri Apr 13 2018)

Categories

(Firefox :: Untriaged, defect)

Unspecified
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 - fixed

People

(Reporter: igoldan, Assigned: aosmond)

References

Details

(Keywords: perf, regression)

We have detected an awsy regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a6f674d433fce89a550c232351885b6f93fe606a&tochange=2efe54944e8cb91f1198d0c55ccb440de5b37997

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 24%  Resident Memory linux64-qr opt stylo     1,172,348,020.08 -> 1,454,359,173.67


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=12712

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/AWSY/Tests
:aosmond This regressions happens only on the Linux x64 QR platform. Is this something we can fix or should we consider accepting it or maybe back it out?
Flags: needinfo?(aosmond)
When bug 1453801 relands, I will ensure this regression is avoided then.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(aosmond)
Resolution: --- → FIXED
Assignee: nobody → aosmond
Target Milestone: --- → Firefox 61
The relanding of the bug's 1453801 new implementation resolved the resident memory regression. As observed by aosmond, we got this regression instead.

== Change summary for alert #12873 (as of Mon, 23 Apr 2018 08:57:28 GMT) ==

Regressions:

 26%  Images linux64-qr opt stylo     5,346,245.37 -> 6,743,586.09

Improvements:

  8%  Resident Memory linux64-qr opt stylo     1,171,507,100.03 -> 1,079,530,212.23

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=12873
Yes. Unfortunately we'll have to accept the images increase -- if you compare it to linux64, they are now very similar, which is what I would expect. WebRender isn't doing anything special to reduce our rasterized image footprint as compared to non-WebRender. As it turns out, we were actually underreporting WebRender consumption due to bugs I resolved in bug 1453801.
You need to log in before you can comment on or make changes to this bug.