Closed Bug 1454386 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 9987 - Ensure cloneNode() does not preserve the prototype

Categories

(Core :: DOM: Core & HTML, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: wptsync, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 9987 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/w3c/web-platform-tests/pull/9987
Details from upstream follow.

Anne van Kesteren <annevk@annevk.nl> wrote:
>  Ensure cloneNode() does not preserve the prototype
>  
>  Closes https://github.com/whatwg/dom/issues/565.
>  
>  It would be great to hear from @bigopon since I cannot reproduce this in Chrome. Given that I'm not sure it's worth adding, but it's probably a good "defense in depth" check.
>  
>  
>
Component: web-platform-tests → DOM
Product: Testing → Core
Ran 1 tests and 133 subtests
OK     : 1
PASS   : 131
FAIL   : 2
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ca808b7aae84
[wpt PR 9987] - Ensure cloneNode() does not preserve the prototype, a=testonly
https://hg.mozilla.org/mozilla-central/rev/ca808b7aae84
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.