Closed Bug 1454471 Opened 2 years ago Closed 2 years ago

Perma Orange TVw - AttributeError: 'MarionetteProtocol' object has no attribute 'navigate'

Categories

(Testing :: General, defect, P5)

Version 3
defect

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jgraham)

References

Details

Attachments

(1 file)

Filed by: nerli [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=173868481&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/QmrnkP_ERW2zw-VbGL9aPQ/runs/0/artifacts/public/logs/live_backing.log

12:00:22  WARNING - AttributeError: 'MarionetteProtocol' object has no attribute 'navigate'
12:00:22  WARNING - 
12:00:22     INFO - TEST-UNEXPECTED-ERROR | /css/css-display/display-contents-details-001.html | 'MarionetteProtocol' object has no attribute 'navigate'
12:00:22     INFO - TEST-INFO took 191ms
12:00:22     INFO - PID 3804 | [Parent 3804, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
12:00:22     INFO - PID 3804 | [Child 3840, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
12:00:22     INFO - PID 3804 | [Parent 3804, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
12:00:22     INFO - PID 3804 | [Child 3776, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
12:00:22     INFO - PID 3804 | [Parent 3804, Gecko_IOThread] WARNING: file z:/build/build/src/ipc/chromium/src/base/process_util_win.cc, line 188
12:00:22     INFO - PID 3804 | *** UTM:SVC TimerManager:registerTimer called after profile-before-change notification. Ignoring timer registration for id: telemetry_modules_ping
12:00:22  WARNING - u'runner_teardown': ()
12:00:22     INFO - certutil | 
12:00:22     INFO - certutil | 
12:00:22     INFO - certutil | 
12:00:22     INFO - Certificate Nickname                                         Trust Attributes
12:00:22     INFO -                                                              SSL,S/MIME,JAR/XPI
12:00:22     INFO - 
12:00:22     INFO - web-platform-tests                                           CT,, 
12:00:22     INFO - 
12:00:24     INFO - PID 3060 | 1523880024345	Marionette	INFO	Listening on port 2828
This seems to only happen in TVw - web-platform test verification - and only on Windows (7 and 10, opt and debug).
Summary: Perma Orange - AttributeError: 'MarionetteProtocol' object has no attribute 'navigate' → Perma Orange TVw - AttributeError: 'MarionetteProtocol' object has no attribute 'navigate'
For the next changeset where the tests got run on Windows it's all fine:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=e2f68d3b03c2fe2c8f489ba179e7dc871acda245&filter-searchStr=tvw

Maybe a temporary glitch? Did retries of the same changeset also fail?
Flags: needinfo?(nerli)
We consider this a perma-failure as we don't usually retrigger these TVv failures
Flags: needinfo?(nerli)
This failure happened during display-contents-details-001.html and contents-suppression-dynamic-001.html, which were added on this push, in bug 1453702. I don't immediately see a connection between the error traceback and the added tests, so I'm wondering if this is a problem in the web-platform test harness. (On the other hand, more recent pushes seem to be passing TVw fine, so maybe this is specific to the new tests?)

:jgraham, do you understand what happened here?


12:00:13     INFO - :::
12:00:13     INFO - ::: Running test verification step "Running tests in a loop 10 times"...
12:00:13     INFO - :::
...
12:00:27     INFO - TEST-START | /css/css-display/display-contents-details-001.html
12:00:27  WARNING - Traceback (most recent call last):
12:00:27  WARNING -   File "Z:\task_1523877961\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 464, in _run
12:00:27  WARNING -     self.result = True, self.func(self.protocol, self.url, self.timeout)
12:00:27  WARNING -   File "Z:\task_1523877961\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 646, in _screenshot
12:00:27  WARNING -     marionette.navigate(url)
12:00:27  WARNING - AttributeError: 'MarionetteProtocol' object has no attribute 'navigate'
12:00:27  WARNING - 
12:00:27     INFO - TEST-UNEXPECTED-ERROR | /css/css-display/display-contents-details-001.html | 'MarionetteProtocol' object has no attribute 'navigate'
12:00:27     INFO - TEST-INFO took 190ms

12:01:57     INFO - :::
12:01:57     INFO - ::: Running test verification step "Running tests in a loop 10 times"...
12:01:57     INFO - :::
...
12:02:04     INFO - TEST-START | /css/css-display/display-contents-suppression-dynamic-001.html
12:02:05  WARNING - Traceback (most recent call last):
12:02:05  WARNING -   File "Z:\task_1523877961\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 464, in _run
12:02:05  WARNING -     self.result = True, self.func(self.protocol, self.url, self.timeout)
12:02:05  WARNING -   File "Z:\task_1523877961\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 646, in _screenshot
12:02:05  WARNING -     marionette.navigate(url)
12:02:05  WARNING - AttributeError: 'MarionetteProtocol' object has no attribute 'navigate'
12:02:05  WARNING - 
12:02:05     INFO - TEST-UNEXPECTED-ERROR | /css/css-display/display-contents-suppression-dynamic-001.html | 'MarionetteProtocol' object has no attribute 'navigate'
Blocks: 1453702
Flags: needinfo?(james)
in test-verify we get a timeout and it looks like we are trying to use marionette.navigate to take a screenshot- possibly the test is not cleaning up properly or written to handle all timing issues.
It's just a bug, but a pretty funny/tragic one. I'll fix it.
Flags: needinfo?(james)
Attachment #8969225 - Flags: review?(ato)
Duplicate of this bug: 1455198
Comment on attachment 8969225 [details]
Bug 1454471 - Unbreak external reftests on wpt,

https://reviewboard.mozilla.org/r/237954/#review243676

rs=me
Attachment #8969225 - Flags: review?(ato) → review+
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/16bb3f3c01cb
Unbreak external reftests on wpt, r=ato
Created web-platform-tests PR https://github.com/w3c/web-platform-tests/pull/10534 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5e5d90268f94
Backed out changeset 16bb3f3c01cb for wpt failures on replacement-enabled.html
Backed out changeset 16bb3f3c01cb (bug 1454471) for wpt failures on replacement-enabled.html

Push with failures: https://is.gd/NLTccA

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=174564167&repo=autoland&lineNumber=11963

Backout link: https://hg.mozilla.org/integration/autoland/rev/5e5d90268f94fc3e47b06b33092f28831ec0daf5
Flags: needinfo?(james)
Upstream PR merged
https://hg.mozilla.org/mozilla-central/rev/68902312e887
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Flags: needinfo?(james)
Assignee: nobody → james
You need to log in before you can comment on or make changes to this bug.