Closed Bug 1454529 Opened 2 years ago Closed 1 year ago

tune nglayout.initialpaint.delay setting

Categories

(GeckoView :: General, enhancement, P3)

Unspecified
Android
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1536781

People

(Reporter: kbrosnan, Assigned: smaug, NeedInfo)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [qf:p1:pageload])

Attachments

(2 files)

Currently Firefox for Android uses 250ms as the value for nglayout.initialpaint.delay. The first option is to use the same settings as desktop 5ms. If we want to spend some time on this we could come up with a custom value that is better than desktop. see bug 1454474 comment 2 for some initial findings.
No longer blocks: 1454477
Depends on: 1454477
bah was right the first time
Blocks: 1454477
No longer depends on: 1454477
Attachment #8968388 - Flags: review?(tnikkel)
Attachment #8968388 - Flags: review?(snorp)
So we're basing this on the load of one site? (bug 1454474 comment 2) Last time we looked at this I believe the extra painting we had to do badly regressed page load speed. Do we have more evidence that this will be a win now?
Flags: needinfo?(kbrosnan)
Comment on attachment 8968388 [details]
bug 1454529 - set nglayout.initialpaint.delay to 5m globally. Removing the Android ifdef.

https://reviewboard.mozilla.org/r/237084/#review243392

I don't think we can take this patch without having a lot of data to suggest that it will improve things. I spent a lot of time on paint suppression a few years ago because painting during page load can dramatically affect performance. If we paint earlier, we'll have more paints, and likely slower load times.
Attachment #8968388 - Flags: review?(snorp) → review-
Comment on attachment 8968388 [details]
bug 1454529 - set nglayout.initialpaint.delay to 5m globally. Removing the Android ifdef.

https://reviewboard.mozilla.org/r/237084/#review243616

I'd be happy to enable trying some new things out in this area but I think we need more data right now to say that this will be a benefit.
Attachment #8968388 - Flags: review?(tnikkel)
Assignee: nobody → kbrosnan
Priority: -- → P3
We may want to run a mobile experiment testing different values of nglayout.initialpaint.delay. Desktop default is 5 ms and Android default is 250 ms.
OS: Unspecified → Android
Whiteboard: [qf]
Whiteboard: [qf] → [qf:investigate]
Depends on: 1506949
I'm testing a patch where the whole ancient paint suppression is removed, but it is on top of a 
patch where painting is slower during page load (after first non-blank paint).

remote: View your change here:
remote:   https://hg.mozilla.org/try/rev/32400c88a4741e998aa913d43f70388120f846e9
remote: 
remote: Follow the progress of your build on Treeherder:
remote:   https://treeherder.mozilla.org/#/jobs?repo=try&revision=32400c88a4741e998aa913d43f70388120f846e9
remote: 
remote: It looks like this try push has talos jobs. Compare performance against a baseline revision:
remote:   https://treeherder.mozilla.org/perf.html#/comparechooser?newProject=try&newRevision=32400c88a4741e998aa913d43f70388120f846e9
remote: recorded changegroup in replication log in 0.027s
I've tried several different approaches to remove Paint Suppression altogether.
remote: Follow the progress of your build on Treeherder:
remote:   https://treeherder.mozilla.org/#/jobs?repo=try&revision=95fcfec03a1388563c44eba0e74e0c0c0d220a60
remote: recorded changegroup in replication log in 0.026s
is the latest variant and closest to pass test. But there is at least one weird wpt failure. That isn't an issue in paint suppression code itself, but something racy, as far as I see.
Assignee: kbrosnan → bugs
Depends on: 1513083
Product: Firefox for Android → GeckoView
Blocks: 1517850
Whiteboard: [qf:investigate] → [qf:p1:pageload]

I think that because of bug 1524806, this doesn't actually need to be p1 anymore, but I'll investigate a bit more.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1536781
You need to log in before you can comment on or make changes to this bug.