Closed Bug 1454633 Opened 2 years ago Closed 2 years ago

Client API doesn't need to use WorkerHolder with status = Closing

Categories

(Core :: DOM: Service Workers, enhancement, P2)

58 Branch
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1457157

People

(Reporter: baku, Assigned: baku)

Details

Attachments

(1 file)

Terminating is the correct WorkerStatus for the Client API because this API is exposed to ServiceWorkers where we don't have close() method.
Attached patch client.patchSplinter Review
Attachment #8968507 - Flags: review?(bkelly)
Attachment #8968507 - Flags: review?(bkelly) → review+
Priority: -- → P2
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/64ca4238a420
Client API doesn't need to use WorkerHolder with status = Closing, r=bkelly
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4989e0da221
Client API doesn't need to use WorkerHolder with status = Closing, r=bkelly
Flags: needinfo?(amarchesini)
Backed out 7 changesets (bug 1450644, bug 1454633) for for failing browser_storage_permission.js

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=f4989e0da2216f6cf3fbe3d3a616d31447f068ec&filter-searchStr=browser-chrome&filter-job_type_symbol=bc3&filter-job_type_symbol=bc6

https://hg.mozilla.org/integration/mozilla-inbound/rev/73615fe67ab6424c9334f95c39a74fc224977993

https://treeherder.mozilla.org/logviewer.html#?job_id=174187061&repo=mozilla-inbound

20:11:19     INFO -  WARNING | IO Completion Port failed to signal process shutdown
20:11:19     INFO -  Parent process 5084 exited with children alive:
20:11:19     INFO -  PIDS: 7296
20:11:19     INFO -  Attempting to kill them, but no guarantee of success
20:11:19     INFO -  TEST-INFO | Main app process: exit 0
20:11:19    ERROR -  948 ERROR TEST-UNEXPECTED-FAIL | dom/serviceworkers/test/browser_storage_permission.js | leaked 2 window(s) until shutdown [url = http://mochi.test:8888/browser/dom/serviceworkers/test/empty.html?storage_permission]
20:11:19     INFO -  TEST-INFO | dom/serviceworkers/test/browser_storage_permission.js | windows(s) leaked: [pid = 6728] [serial = 40], [pid = 6728] [serial = 42]
20:11:19     INFO -  runtests.py | Application ran for: 0:03:30.185000
20:11:19     INFO -  zombiecheck | Reading PID log: c:\users\task_1523994445\appdata\local\temp\tmpa_ftpcpidlog
20:11:19     INFO -  ==> process 5084 launched child process 8040 ("Z:\task_1523994445\build\application\firefox\firefox.exe" -contentproc --channel="5084.0.1628532536\581954630" -childID 1 -isForBrowser -prefsHandle 2040 -prefsLen 16433 -schedulerPrefs 0001,2 -greomni "Z:\task_1523994445\build\application\firefox\omni.ja" -appomni "Z:\task_1523994445\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1523994445\build\application\firefox\browser" - 5084 "\\.\pipe\gecko-crash-server-pipe.5084" 2084 tab)
20:11:19     INFO -  ==> process 5084 launched child process 6728 ("Z:\task_1523994445\build\application\firefox\firefox.exe" -contentproc --channel="5084.6.2006398579\1445751292" -childID 2 -isForBrowser -prefsHandle 2432 -prefsLen 16433 -schedulerPrefs 0001,2 -greomni "Z:\task_1523994445\build\application\firefox\omni.ja" -appomni "Z:\task_1523994445\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1523994445\build\application\firefox\browser" - 5084 "\\.\pipe\gecko-crash-server-pipe.5084" 2444 tab)
20:11:19     INFO -  ==> process 5084 launched child process 4984 ("Z:\task_1523994445\build\application\firefox\firefox.exe" -contentproc --channel="5084.12.1142979272\2112065260" -childID 3 -isForBrowser -prefsHandle 3464 -prefsLen 22004 -schedulerPrefs 0001,2 -greomni "Z:\task_1523994445\build\application\firefox\omni.ja" -appomni "Z:\task_1523994445\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1523994445\build\application\firefox\browser" - 5084 "\\.\pipe\gecko-crash-server-pipe.5084" 3336 tab)
20:11:19     INFO -  ==> process 5084 launched child process 3088 ("Z:\task_1523994445\build\application\firefox\firefox.exe" -contentproc --channel="5084.18.301647013\1202071366" -childID 4 -isForBrowser -prefsHandle 3332 -prefsLen 22099 -schedulerPrefs 0001,2 -greomni "Z:\task_1523994445\build\application\firefox\omni.ja" -appomni "Z:\task_1523994445\build\application\firefox\browser\omni.ja" -appdir "Z:\task_1523994445\build\application\firefox\browser" - 5084 "\\.\pipe\gecko-crash-server-pipe.5084" 3628 tab)
20:11:19     INFO -  zombiecheck | Checking for orphan process with PID: 8040
20:11:19     INFO -  zombiecheck | Checking for orphan process with PID: 6728
20:11:19     INFO -  zombiecheck | Checking for orphan process with PID: 4984
20:11:19     INFO -  zombiecheck | Checking for orphan process with PID: 3088
20:11:19     INFO -  Stopping web server
20:11:19     INFO -  Stopping web socket server
20:11:19     INFO -  Stopping ssltunnel
20:11:19     INFO -  TEST-INFO | leakcheck | default process: leak threshold set at 0 bytes
20:11:19     INFO -  TEST-INFO | leakcheck | plugin process: leak threshold set at 0 bytes
20:11:19     INFO -  TEST-INFO | leakcheck | tab process: leak threshold set at 1000 bytes
20:11:19     INFO -  TEST-INFO | leakcheck | geckomediaplugin process: leak threshold set at 20000 bytes
20:11:19     INFO -  TEST-INFO | leakcheck | gpu process: leak threshold set at 0 bytes

https://treeherder.mozilla.org/logviewer.html#?job_id=174181622&repo=mozilla-inbound&lineNumber=2211
Flags: needinfo?(amarchesini)
bkelly changed clients API. This patch is not needed anymore.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1457157
You need to log in before you can comment on or make changes to this bug.