Can't save the profile data

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
17 years ago
a day ago

People

(Reporter: smaug, Assigned: rginda)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When trying to save the profile data I get the followind message:
[Exception... "Not enough arguments [nsIFileOutputStream.init]" nsresult:
"0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)" location: "JS frame ::
chrome://venkman/content/file-utils.js :: LocalFile :: line 242" data: no]

This is a regression of bug 126829.
(Reporter)

Comment 1

17 years ago
Created attachment 84163 [details] [diff] [review]
Patch v1

Because the behaviorFlags aren't currently supported,
the parameter could be 0?
See
http://lxr.mozilla.org/seamonkey/source/netwerk/base/public/nsIFileStreams.idl#88

Comment 2

17 years ago
confirmed with 1.0rc2 and trunk build 20020519
marking NEW

severity=> major (this totally breaks saving profile data)

keyword regression, patch
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: patch, regression
OS: Windows 98 → All
Hardware: PC → All
(Assignee)

Comment 3

17 years ago
Comment on attachment 84163 [details] [diff] [review]
Patch v1

r=rginda
Attachment #84163 - Flags: review+
(Assignee)

Comment 4

17 years ago
We should get this in for 1.0.
Status: NEW → ASSIGNED
Keywords: mozilla1.0

Comment 5

17 years ago
Damn, I missed that.  Thanks.  0 is good.

Comment 6

17 years ago
Comment on attachment 84163 [details] [diff] [review]
Patch v1

a=chomann,brenda,etc
Attachment #84163 - Flags: approval+
(Assignee)

Comment 7

17 years ago
checked in to branch and trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Core → Other Applications

Updated

a day ago
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.