Closed Bug 1454798 Opened 4 years ago Closed 4 years ago

Intermittent /eventsource/dedicated-worker/eventsource-close2.htm | application crashed [@ mozilla::dom::EventSourceImpl::DispatchFailConnection]

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1455057

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: assertion, crash, intermittent-failure, Whiteboard: [retriggered])

Crash Data

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=174182416&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/MqH4Jw1cQZemPs0w8kGfwg/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-17T19:48:18.724Z] 19:48:18     INFO - PID 4443 | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[task 2018-04-17T19:48:19.008Z] 19:48:19     INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/YrSTBiPeRjyvx0WdTlD0ng/artifacts/public/build/target.crashreporter-symbols.zip
[task 2018-04-17T19:48:24.358Z] 19:48:24     INFO - mozcrash Copy/paste: /usr/local/bin/linux64-minidump_stackwalk /tmp/tmp52aXaa.mozrunner/minidumps/33b5682d-a421-c905-b488-e2671927457a.dmp /tmp/tmp6eflh8
[task 2018-04-17T19:48:30.297Z] 19:48:30     INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/33b5682d-a421-c905-b488-e2671927457a.dmp
[task 2018-04-17T19:48:30.298Z] 19:48:30     INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/33b5682d-a421-c905-b488-e2671927457a.extra
[task 2018-04-17T19:48:30.424Z] 19:48:30     INFO - PROCESS-CRASH | /eventsource/dedicated-worker/eventsource-close2.htm | application crashed [@ mozilla::dom::EventSourceImpl::DispatchFailConnection]
[task 2018-04-17T19:48:30.424Z] 19:48:30     INFO - Crash dump filename: /tmp/tmp52aXaa.mozrunner/minidumps/33b5682d-a421-c905-b488-e2671927457a.dmp
[task 2018-04-17T19:48:30.424Z] 19:48:30     INFO - Operating system: Linux
[task 2018-04-17T19:48:30.425Z] 19:48:30     INFO -                   0.0.0 Linux 4.4.0-1014-aws #14taskcluster1-Ubuntu SMP Tue Apr 3 10:27:00 UTC 2018 x86_64
[task 2018-04-17T19:48:30.425Z] 19:48:30     INFO - CPU: x86
[task 2018-04-17T19:48:30.426Z] 19:48:30     INFO -      GenuineIntel family 6 model 62 stepping 4
[task 2018-04-17T19:48:30.426Z] 19:48:30     INFO -      4 CPUs
[task 2018-04-17T19:48:30.426Z] 19:48:30     INFO - 
[task 2018-04-17T19:48:30.426Z] 19:48:30     INFO - GPU: UNKNOWN
[task 2018-04-17T19:48:30.427Z] 19:48:30     INFO - 
[task 2018-04-17T19:48:30.427Z] 19:48:30     INFO - Crash reason:  SIGSEGV
[task 2018-04-17T19:48:30.428Z] 19:48:30     INFO - Crash address: 0x0
[task 2018-04-17T19:48:30.428Z] 19:48:30     INFO - Process uptime: not available
[task 2018-04-17T19:48:30.429Z] 19:48:30     INFO - 
[task 2018-04-17T19:48:30.429Z] 19:48:30     INFO - Thread 0 (crashed)
[task 2018-04-17T19:48:30.430Z] 19:48:30     INFO -  0  libxul.so!mozilla::dom::EventSourceImpl::DispatchFailConnection [EventSource.cpp:7d1e0a7e3e132be75e742565faeec60d12d2d94c : 1334 + 0x1d]
[task 2018-04-17T19:48:30.430Z] 19:48:30     INFO -     eip = 0xefce92ed   esp = 0xffe25dc0   ebp = 0xffe25df8   ebx = 0xf54ea000
[task 2018-04-17T19:48:30.431Z] 19:48:30     INFO -     esi = 0x80004005   edi = 0xffe25dd8   eax = 0x00000000   ecx = 0xf755b864
[task 2018-04-17T19:48:30.431Z] 19:48:30     INFO -     edx = 0x00000000   efl = 0x00010282
[task 2018-04-17T19:48:30.432Z] 19:48:30     INFO -     Found by: given as instruction pointer in context
[task 2018-04-17T19:48:30.432Z] 19:48:30     INFO -  1  libxul.so!mozilla::dom::EventSourceImpl::OnStopRequest [EventSource.cpp:7d1e0a7e3e132be75e742565faeec60d12d2d94c : 807 + 0x9]
[task 2018-04-17T19:48:30.432Z] 19:48:30     INFO -     eip = 0xefce9817   esp = 0xffe25e00   ebp = 0xffe25e48
[task 2018-04-17T19:48:30.432Z] 19:48:30     INFO -     Found by: previous frame's frame pointer
[task 2018-04-17T19:48:30.432Z] 19:48:30     INFO -  2  libxul.so!nsCORSListenerProxy::OnStopRequest [nsCORSListenerProxy.cpp:7d1e0a7e3e132be75e742565faeec60d12d2d94c : 651 + 0x17]
[task 2018-04-17T19:48:30.433Z] 19:48:30     INFO -     eip = 0xef3a47b5   esp = 0xffe25e50   ebp = 0xffe25ea8
[task 2018-04-17T19:48:30.433Z] 19:48:30     INFO -     Found by: previous frame's frame pointer
[task 2018-04-17T19:48:30.434Z] 19:48:30     INFO -  3  libxul.so!mozilla::net::nsHttpChannel::OnStopRequest [nsHttpChannel.cpp:7d1e0a7e3e132be75e742565faeec60d12d2d94c : 7419 + 0x22]
[task 2018-04-17T19:48:30.434Z] 19:48:30     INFO -     eip = 0xef3cf36f   esp = 0xffe25eb0   ebp = 0xffe25fe8
[task 2018-04-17T19:48:30.434Z] 19:48:30     INFO -     Found by: previous frame's frame pointer
[task 2018-04-17T19:48:30.435Z] 19:48:30     INFO -  4  libxul.so!nsInputStreamPump::OnStateStop [nsInputStreamPump.cpp:7d1e0a7e3e132be75e742565faeec60d12d2d94c : 708 + 0x15]
[task 2018-04-17T19:48:30.435Z] 19:48:30     INFO -     eip = 0xef152cca   esp = 0xffe25ff0   ebp = 0xffe26058
[task 2018-04-17T19:48:30.435Z] 19:48:30     INFO -     Found by: previous frame's frame pointer
This is a crash caused by the following assertion:

https://treeherder.mozilla.org/logviewer.html#?job_id=174259588&repo=mozilla-inbound&lineNumber=16808-16827

[task 2018-04-18T03:39:24.312Z] 03:39:24     INFO - PID 4343 | Assertion failure: ((bool)(__builtin_expect(!!(!NS_FAILED_impl(rv)), 1))), at /builds/worker/workspace/build/src/dom/base/EventSource.cpp:1334
[task 2018-04-18T03:39:24.321Z] 03:39:24     INFO - PID 4343 | #01: mozilla::dom::EventSourceImpl::DispatchFailConnection() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.325Z] 03:39:24     INFO - PID 4343 | #02: mozilla::dom::EventSourceImpl::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.332Z] 03:39:24     INFO - PID 4343 | #03: nsCORSListenerProxy::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.336Z] 03:39:24     INFO - PID 4343 | #04: mozilla::net::nsHttpChannel::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.344Z] 03:39:24     INFO - PID 4343 | #05: nsInputStreamPump::OnStateStop() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.348Z] 03:39:24     INFO - PID 4343 | #06: nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.356Z] 03:39:24     INFO - PID 4343 | #07: nsInputStreamReadyEvent::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.357Z] 03:39:24     INFO - PID 4343 | #08: nsThread::ProcessNextEvent(bool, bool*) [clone .part.291] (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.358Z] 03:39:24     INFO - PID 4343 | #09: NS_ProcessNextEvent(nsIThread*, bool) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.359Z] 03:39:24     INFO - PID 4343 | #10: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.361Z] 03:39:24     INFO - PID 4343 | #11: MessageLoop::RunInternal() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.362Z] 03:39:24     INFO - PID 4343 | #12: MessageLoop::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.363Z] 03:39:24     INFO - PID 4343 | #13: nsBaseAppShell::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.363Z] 03:39:24     INFO - PID 4343 | #14: nsAppStartup::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.364Z] 03:39:24     INFO - PID 4343 | #15: XREMain::XRE_mainRun() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.365Z] 03:39:24     INFO - PID 4343 | #16: XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.366Z] 03:39:24     INFO - PID 4343 | #17: XRE_main(int, char**, mozilla::BootstrapConfig const&) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-18T03:39:24.367Z] 03:39:24     INFO - PID 4343 | #18: do_main(int, char**, char**) (/builds/worker/workspace/build/application/firefox/firefox)
[task 2018-04-18T03:39:24.368Z] 03:39:24     INFO - PID 4343 | #19: main (/builds/worker/workspace/build/application/firefox/firefox)

Ming-Shou, you fixed something similar on bug 1398030 for Firefox 58. Could you have a look at this assertion/crash too?
Flags: needinfo?(stone123456)
Keywords: assertion
Also interesting are the lines before the assertion:

[task 2018-04-18T03:39:24.189Z] 03:39:24     INFO - PID 4343 | [4343, Main Thread] WARNING: NS_ENSURE_TRUE(aSecondURI) failed: file /builds/worker/workspace/build/src/dom/base/ThirdPartyUtil.cpp, line 98
[task 2018-04-18T03:39:24.307Z] 03:39:24     INFO - PID 4343 | [4343, Main Thread] WARNING: A runnable was posted to a worker that is already shutting down!: file /builds/worker/workspace/build/src/dom/workers/WorkerPrivate.cpp, line 1641
[task 2018-04-18T03:39:24.308Z] 03:39:24     INFO - PID 4343 | [4343, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/worker/workspace/build/src/dom/base/EventSource.cpp, line 703
[task 2018-04-18T03:39:24.312Z] 03:39:24     INFO - PID 4343 | [4343, Main Thread] WARNING: A runnable was posted to a worker that is already shutting down!: file /builds/worker/workspace/build/src/dom/workers/WorkerPrivate.cpp, line 1641
[

Looks like we are trying to dispatch "dom::EventSourceImpl::AnnounceConnection" while the worker is already shutting down.
Summary: Intermittent /eventsource/dedicated-worker/eventsource-close2.htm | application crashed [@ mozilla::dom::EventSourceImpl::DispatchFailConnection] → Permanent false-positive /eventsource/dedicated-worker/eventsource-close2.htm | application crashed [@ mozilla::dom::EventSourceImpl::DispatchFailConnection]
Wups, wrong bug.
Summary: Permanent false-positive /eventsource/dedicated-worker/eventsource-close2.htm | application crashed [@ mozilla::dom::EventSourceImpl::DispatchFailConnection] → Intermittent /eventsource/dedicated-worker/eventsource-close2.htm | application crashed [@ mozilla::dom::EventSourceImpl::DispatchFailConnection]
Flags: needinfo?(amarchesini)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1455057
Flags: needinfo?(stone123456)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.